Can not install any rockon 4.0.8-0

I’m new to Rockstor.
I did try CentOS based one a year ago and really liked it but my hardware was not really up to scratch and used USB flash for boot drive which was not optimal. This time I have removed the failing hardware and use SSD for boot drive. The installation went flawless and created a pool and a share and a Samba export for use on my Windows machine. So far so good.

I did use a couple of Rock-ons on the first installation (CentOS based one) and they all worked amazing. I like that feature. And wanted to install a couple on my new installation.

Wanted to try Zoneminder and Pi-hole and a couple of others. But it seems like I can not install any Rock-on at all. And as I’m pretty new to Rockstor and not really versatile on Linux I don’t really know where to start troubleshooting.

I tried looking into the var\log catalog for hints but what I got there was (not exactly but similar) to like File not found (Zoneminder) type of errors in rockstor.log

I tried installing every version (3 of them?) on the Rockons page but to no avail.

Then I tried a manual install, following the this:

And I did download/install.

Tried running it and no errors… But I can not connect so I guess I need to edit some config file somewhere? can anyone give me some hints?

Or should I just install the CentOS based Rockstor?


@AlexW Welcome to the Rockstor community.

Can you say what happens when you try?

It could well be that our Zoneminder rock-ons need attention. But we haven’t had other recent reports of this. But it does seem suspicious that all versions would fail.

Manual installs of software outside of Rock-ons is not recommended except for expert users really. And further to that it can then interfer with future function of similar Rock-ons. So best to uninstall any custom installs and sort the Rock-on issue first.

No, Rock-ons are working just fine in the v4 and we can no longer release fixes for the CentOS variant. Plus it’s well old now. The “Built on openSUSE” v4 is now recommended for new installs and is at stable release candidate 10, (4.0.9-0) as it’s latest release. Althoght there were no Rock-on related fixes between 4.0.9-0 and 4.0.8-0.

Check that you have the Rock-on system setup as we document here:

Try installing for instance the netdata rock-on and let us know if that works for you.
“Netdata (official) Rock-on”:

It may be that you are not adequately configuring the appropriate shares. Some Rock-on require that you arrange read-write access to the shares you assign to them. Usually by owner or group configuration. So be sure to check that sort of thing. The mouse over hints against each share as you install the Rock-on should say if this is required.

Hope that helps.


It differs but when I finish the guide for installing and switch to the rockon main page a grey square with the snippets of text appears (from the rockon I’m trying to install) and it says installing. Then after while it disappear and when checking the all the rockons it says installation failed.

I really think I’m doing something wrong though. But I really don’t know what yet :slight_smile:
Ok so the manual install have to be removed I guess. I’ll try this

Oh I see what I did wrong there! I did the not recommend thing and used the home share. I now made a Rockons share and changed the Rockons service to use that one. Tried Zoneminder Latest (but still won’t work) but after that I tried the Netdata and it worked perfectly! And that was also something I wanted to install! so that is really nice to get working!

So thanks for your help! I now know that it works (Netdata worked!) so I’ll need to see what I’m doing wrong with Zoneminder but it is fun troubleshooting stuff, and you learn something from it.

Going to pay for 1 years sub because I really like this!
Thanks again for pointing me in the right direction!