Cannot Install 3.9.1 (Soft Lockup - CPU Stuck)

I’m trying to install Rockstor 3.9.1, from the ISO, downloaded from https://sourceforge.net/projects/rockstor/files/. It gets to the Rockstor splash screen and I select Install Rockstor. However, after selecting to install, I start seeing error messages and the install never completes.

After the “[ OK ] Mounted Configuration File System.” message, I start seeing “Bug: soft lockup - CPU#x stuck for 22s! [systemd-udevd:644]” errors:

Screenshot

I’m trying to install on a SuperMicro SuperStorage 5028R-E1CR12L server (https://www.supermicro.com/en/products/system/2U/5028/SSG-5028R-E1CR12L.cfm), with the SuperMicro X10SRH-CLN4F motherboard and a single Intel Xeon E5-2620v3 2.40 GHz six Cores Processor.

NOTE: I also tried to install vanilla CentOS 7 and I get the same error messages.
NOTE: I was able to successfully install FreeNAS, so it’s seems to be a Linux issue, maybe specific to CentOS/RedHat.

Any ideas on how to resolve this?

@HB7 Welcome the Rockstor community.

This is likely due to a kernel or kernel driver incompatibility, likely due to our now old 3.9.1 CentOS base.

Yes, you could build yourself a Release Candidate stage Rockstor 4 installer. It’s on the verge of being our next stable release and has far newer everything than are rather old prior installer and we are now based on openSUSE Leap 15.2.

Take a look at the following GitHub repo for our open source Rockstor 4 installer maker:

The following forum thread was it’s introduction:

No downloads yet but when there is they will be build in exactly the same way. Only likely more out of date that one you build for yourself as during the build process all current packages across the board, bar the rockstor package itself, are pre-installed.

If you have difficulties with this process start a fresh forum thread detailing how far you got and what’s not working as expected.This will hopefully lead to better documentation as we move ever closer to the final release which will be the start of a new Stable channel run. N.B we do have a hopefully last outstanding issue where stable subscription is fault, but I hope to release a fix for that in testing later today.

Hope that helps.

2 Likes

That did resolve the problem. I have successfully installed Rockstor 4.0.4-0.

Thanks!

1 Like

@HB7 Glad you got it sorted, and thanks for the update. This is still a pre-release on Stable but we are on Release Candidate 5 so almost there if not already there. Just watching of any show stopper bugs really.

Well done on rolling your own DIY installer. At least this way the installs have all pending updates pre-installed which is nice.

Thanks for the update and keep us informed of how it goes. We are really hoping to call this one our first Stable release of the “Built on openSUSE” endeavour. Plus we need to move on very soon with the testing channel again so it would be a win all around if can finally name a new Stable version.