Cannot Install from USB

Motherboard: Supermicro X11SAE-F, BIOS 2.3
16GB ram
Processor: Xeon E3-1225 V6

I have 6 SSDs connected to the onboard SATA ports of the motherboard. All 6 drives are empty/new and have not been formatted.

When I plug in a bootable USB (tried with multiple USB sticks) with the Rockstor installation files and select the version to install (regular or failsafe), the installer begins to run, hangs for a while on dracut-initque, then spits out errors for a while and ends with Warning: /dev/disk/by-label/INSTALL does not exist. The installer then enters emergency mode, and I use Ctrl+D t continue, but after selecting the SSD I would like to use to install Rockstor I get a “Failed to mount install ISO device” message and the system restarts.

@kou Welcome to the Rockstor community forum.

Do you mean the downloadable installer images available here:

And how did you transfer the installer image to the USB device that you are using to boot the installer. That can be very important, linux advise is given on the downloads page and our quickstart guide gives info on creating the images on the other main OSs.

You could also try modifying the bios options regarding UEFI BIOS/legacy etc.

The full expected, and tested, installer progress is in the following Howto:

Also could you given the version of installer you are experiencing this with. Are you using our latest 4.5.6-0 version? And be sure to use the one based on Leap 15.4 as 15.3 is now EOL and provided only as a fall back to those who’s hardware is still having issues with the newer kernel in 15.4.

Hope that helps. And let us know how you get on, or if you make any more progress.


Hopefully the following clarifies my initial post, which wasn’t the best:

I have been trying to get Rockstor NAS software installed on a bare system with new SSDs from an ISO on a USB stick created with dd .

The loader allows me to select Install-Rockstor_Leap15.4-generic and then appears to start loading, but hangs up at Starting dracut initque hook... , then eventually gives me a starting emergency shell message and generates rdsosreport.txt .

Using cat to view this file, it looks like the problem may have to do with the following:

-e "/dev/disk/by-label/INSTALL"

As INSTALL is the name of my USB drive containing the ISO. After multiple timeouts with this error, I eventually get a Warning: could not boot .

1 Like

Ok I created the ISO using both dd and balenaEtcher on Mac, and both failed similarly. However, I created an ISO using balenaEtcher on Windows and was able to install from there!


I have had the same issue with Balena Etcher not always working on either legacy or UEFI bios. For Windows it has always worked, but for Linux it hasn’t. Next time try Rufus, it’s been much more reliable.


@phillxnet, @Flox,

My apologies for re-visiting this issue, but I have run into the same or a similar problem when trying to install Rockstor on older hardware with a USB-connected MSATA drive.

@stitch10925 Hello again.

Our entire boot/installer arrangement basically comes from our upstream of kiwi-ng these days. And be build our installers via the following wiki-ng config:

Take a look at that config, you may see something that could help. Our recent 4.5.8-0 installers were build which what appears, as of this post, in that repo. Also note that we now have Tumbleweed based installers, that could be worth a try. Do take note on our downloads page of the intended audience there however as Leap 15.4 is our current main target. But you may be up for living on the edge. Or it may be informative to know of the TW installer works for example.

Not of much help I know but it may be that this USB-to-MSATA driver has some issues in the Leap kernels but works just dandy in the cutting edge TW kernels for example.

I’m not quite sure exactly where you are seeing the hold-up so difficult to comment.

Hope that helps, if only a little.


Hey @phillxnet,

Thanks for the reply. I quickly tried Tumbleweed yesterday evening, but alas, no success. I will pull the logs this week so I can post them.

I haven’t tried Leap15.3 yet, but I’d be surprised if that worked.