Cannot install plex or emby


I have tried to install plex or emby on rockstor 3.9.2-47

Having followed the rockstor documentation to install plex rock-on or emby rock-on in rockstor.

I have notice the plex install wizard is not showing the resource type e.g Env 1001 PUID, Env 1001 GUID, Env latest VERSION

This is before the install of the rock-on has started.

Is there a way I can get the plex or emby rock-on installed on the rockstor server?

Enclosed is a gui screen shot of the plex install wizard before I submit it for installation.

Hi @mwlee and welcome!

That is actually a display bug that I didn’t notice before, which means I may have been responsible for introducing it :frowning:… Note that this is only a display issue and that the ENV variables are actually passed onto the docker run command. I just tried to install the Plex rock-on on my dev machine the install went fine and I can access the Plex UI. As you can see below the ENV variables are passed correctly:

/opt/build/var/log/rockstor.log:[31/Mar/2019 08:55:49] DEBUG [system.osi:104] Running command: /usr/bin/docker run -d --restart=unless-stopped --name -v /mnt2/plex-conf:/config -v /mnt2/plex-data:/data -v /etc/localtime:/etc/localtime:ro -p 32400:32400/tcp -p 32400:32400/udp --net=host -e VERSION=latest -e PUID=1000 -e PGID=1000 linuxserver/plex

I believe I see a possible explanation as to why they are not displayed as they should be, but the rock-on install process itself should not suffer from it. I’ll try to correct that as soon as I can.

Sorry for this display issue, but try to go further with the install and see whether you encounter any additional issue.

1 Like

Linking to the Github issue you created (thanks!)…

… as well as the corresponding PR fixing the ENV display issue:

1 Like

Many thanks for responding to the issue with plex.
I have tried a number of times to install the plex rock-on.

After the install the rock-on service, states 'There are no Rock-ons installed currently.

Is there anything I can do to rectify the above issue?

Let’s try to see what is happening there, the install of some rock-ons can take a little while sometimes and cause this kind of oddity in the UI. Sometimes I’ve seen a simple page reload (Ctrl + R or Ctrl + Shift + R on chromium-based browsers) or clicking the Update button fix this but that is an aspect we still need to improve.
From your message, I understand you did not encounter a proper error message, so I would expect the rock-on install did proceed correctly, although I seem to see in your earlier screenshot an error message stating that the previous Plex install failed. Could you clarify this?
If the former is true, then you could verify that the underlying docker container is indeed running as expected by running docker ps -a.
If the latter is true, I would recommend you to look into the logs listed in the error message (rockstor.log) for a relevant error message around the time of the install attempt.

Hopefully we’ll have a better idea of what the problem is.