Cant acces server page from home computer


I have had a issue accesing my server from my computer the last 14 days. From my phone it is not a problem.

I get this errormessage when i try to acces it:


Anybody with ideas on hot to fix it?

nobody experiencing the same thing? :confused:

@KaiHai Hello again.
As this is a browser ‘complaint’ it might help to know which browser you are experiencing this issue with. Haven’t seen it myself but others may well be able to offer more advise with this info.

Hope that helps.

Hi Phil,

Sorry, should off course have included that :slight_smile:

I primarly use Chrome, but have also tested with Microsoft edge without any luck. I also have Chrome on my phone which works.

Have been able to acces without problems since my initial installation (1.5 ish years ago), but now not possible.

Hope this helps


nobody with some experience? :confused:

I am not experiencing this issue but after quick Googling, it appears to result from a “recent” change in browsers. The issue seems more tricky to circumvent in Chrome, but Firefox, for instance, should be much easier to use for that.
See here:

or here:

Hope this helps,

1 Like


Thanks for reply :slight_smile:
It works with opera (just tested) so this seem to be a chrome issue. Cant say i am happy with needing a separate browser for Rockstor, but hopefully Chrome will work after some time?

If not, how do one make a new certificate for Rockstor?


Glad you got it to work.

Regarding how to make it work with chrome, I’m afraid it’s beyond my skills.


Creating certificates for Rockstor is the same as any other system.
If you wish to create your own self-signed certificate, you can follow this guide (Ignoring the Apache configuration at the end).
This will provide you with three files, a CSR (Certificate signing request), CRT (The actuall SSL certificate) and KEY (The private key to pair with the CRT.)

To import the certificate into rockstor, you’ll need to go to System -> SSL Certificate, then select ‘Update SSL Certificate’.
You’ll need the contents of the CRT and KEY files here.

If you wish to have a certificate that will not throw warnings in a browser - this is a more complex story.
You’ll need a domain name (You can register one at any domain registrar, such as OnlyDomains), the same hostname (or a subdomain thereof) on your rockstor box, and:

For LetsEncrypt (free SSL):
An externally available static IP address or solid DynDNS config
Forwarding rules to ensure web traffic can get to your Rockstor box
Something to answer on LetsEncrypt (Such as the haproxy-letsencrypt rockon, which you can then configure as a forward proxy for all your other rockons)

For purchased SSL certificates (Providers like DigiCert, Comodo or Symantec):
Ability to add DNS records on the fly (for domain validation)

So long time since i posted here. Settled with beeing able to acces from edge and phone, but now i cant acces web GUI at all. Any tips?`:/


Not without a bit more description.
When you attempt to access the Web UI, what error message(s) are you receiving from the browser?
What URL are you accessing? (Direct IP, or a hostname?)
Is the rockstor service running?

systemctl is-active rockstor

Can you still acces the system via the CLI (SSH)?
Can you provide the latest logs from Rockstor via the terminal?

1 Like

Thanks for quick reply :slight_smile:

From Edge i get : No secure connection. So i downloaded Vivaldi which seemed to be a “up to the user what to do kind of browser” :slight_smile: there the message is “ERR_CONNECTION_REFUSED”. I try to connect directly to the IP found on my router home page.

Rockstor is running (i use it primairly for plex and that works fine).

I havent used the direct approach like that in a while since when it works it works :stuck_out_tongue: But i have full acces to the folders where i store my media from this computer so indications says i will. I can check if you could refresh my memory on the program used to acces (i think that was not a innstalled program, but something i run directly?)

Hoping for a short intro back to the direct acces :slightly_smiling_face:


Hi @KaiHai,

You’ll need something like PuTTY to SSH into your Rockstor system.
It sounds like the box itself is running fine, but the Web-UI has crashed.
This is managed by the a system service named rockstor.

Once you’re SSH’d into the system, try running:

# systemctl is-active rockstor || \
systemctl restart rockstor || \
jounalctl -u rockstor -n 30

This command will:

  • Check the rockstor service is running
  • If not, restart it
  • If the restart fails, output the last 30 log lines from that service

@Haioken I wondered if, from the following:

if this was just an attempt to connect via http rather than the required https, and given there is also mention of security:

if it was also https certificate complaints from the used browsers when https was used.

That’s how I read this anyway. There would also seem to be some translation going on here as well so that makes it a little harder to fathom @KaiHai’s predicament.

I’m probably chipping in unnecessarily here.


Good catch, should’ve thought of that :confused:

On the contrary, my real life job is to throw shit at the wall to see what sticks (System Administrator), so having somebody actively working on Rockstor weigh in is likely always a better option ;o)

Morning Guys :slight_smile:
Sorry for late reply, but hectic days before christmas with alot of birthdays as well :slight_smile: So i tried various things including putty (jounalctl didnt workm neither did journalctl?), but Phil spotted is, i allways just type the internal IP and nothing more, but when adding https it worked :slight_smile:
so as allways, thank you very much for your help and have a great weekend, christmas :slight_smile: