Can't access Shadow copies

Hi guys, I have scheduled BTRFS snapshots and everything was working great, I have enabled shadow copies and was able to access them. Looking at some of my snapshots couple of days ago and I wasn’t able to access them because I don’t have permissions. Disabled this task and created a new one for the same share, snapshots were taken successfully but again I am unable to access the shadow copies via Windows. Please check the pic below.

This is the share permissions.

Not sure, if anyone cares to reply. I just wanted to add up even after I have created a fresh new share with the appropriate permissions and setting the schedule BTRFS snapshots. If I go to the previous versions of the share I can’t access any of the data so the previous versions are unusable. I don’t know but it looks like there is a bug somewhere, since the previous versions were working before but after I upgraded to 3.9.1-16 I noticed this issue.

I’ve been interested in doing that, but aside from scheduling snapshots I have not worked on making these visible to Windows. What additional setup did you do for a windows client to be able to see the snapshots as previous versions?
I assume, this has to be done using the Samba functionality (VFS), which requires additions to the config file. Is that correct? Did you add these parameters then as part of the share mount options, since Rockstor kind of controls the Samba config file?
I might not be able to help you, but if I know how you set it up, I can try it on my environment and see whether it works or whether I am running into the same issue.

Hey mate, I have set the snapshots over a year ago. All needs to be done was turning on samba, creating the share and enabling Shadow copies on the share, adding the appropriate prefix so I can allow the schedule BTRFS snapshots to work. Previously there was a bug on Rockstor where you have to add some line in the samba config to allow Windows users to access the share without entering the password everytime, other than that I never changed any settings, and previous versions was always on my shares and I was able to access them.

To clarify I am talking about the content of the previous versions, which is like the apps folder in the picture above. I made my snapshots visible but I wasn’t talking about accessing them, was more about other contents residing under the parent folder.

Thank you for the explanation. I will see whether I can get it to work. Of course, I don’t have a reference :slight_smile: since I did not enable it during the time when it worked for you as well.

1 Like

Well, no luck so far … I even explicitly injected some of the shadow copy config into the samba config file and … nothing. The samba logs don’t show me any errors after restarting the service. I dabbled with the naming convention of the snapshots, but Windows is just not picking it up as “previous version”

Then again the last windows 10 creator’s update (I think November 2017) seemed to have broken some Samba functionality (visibility in network - which used to work just fine to see the rockstor server and now it’s not) …

I don’t think it’s anything to do with Windows 10, I am running here Windows 10 at work latest build and using shadow copies but not rockstor just Windows server, so if it was Windows 10 it should be broken at work as well. I think it’s something to do with the latest update of rockstor, no one has faced the problem yet hopefully @phillxnet or @suman_chakravartula can help me out with this one.

@Mahmoud87 Hello again.

@Flyer may well be able to help on this one as he’s done a number of samba fixes / improvements along the way in Rockstor. But not sure if he is still watching the forum. We haven’t had any other recent reports of shadow copy regressions however. But don’t really know how popular this feature is with Rockstor users. Only samba change as been an upstream update from around 4.4.4 to 4.6.x so that might be related.

Lets give it a little more time to see if we can get any more info, feedback, or input on this one.

1 Like

I’m always here, checking every day @phillxnet :wink:

Shadow copies should work fine, samba updates have fixes, but samba shadow copies vfs component should be always the same :slight_smile:



Thanks @phillxnet and @Flyer for your response however it’s not working for me anymore. It used to be working till I have upgraded to 3.9.1-16. I haven’t done any changes, and previously I was able to access the contents of the previous versions and get the data I need from the particular date\time and take a copy of this data, now I can’t open folders from previous versions, can’t do any copy and surely I can’t restore. What can I do to troubleshoot the problem?

Well, the win10 update to 1709 broke visibility to Samba shares on non-Windows servers (like Rockstor) for quite a few people (including myself). I can still get to my Rockstor using the IP address and/or map a drive to it, however, the “automagic” appearance of Rockstor in the Windows Networking area does not happen anymore (since December).

That’s why I was thinking that this might cause greater issues in other areas as well. But … I’d prefer if that wasn’t the root cause :).

Morning all,
thanks to @Hooverdan : had some checks over google and can confirm some users got same issue and it seems Windows 10 related since Creators Update (Windows 10 1703)

Shadow copies seem to work on root folder.
Hope to find time to have an ad hoc Rockstor env and check it


thanks for the guidance about it friends it’s really helpful. :smile:

Hey guys, any update on this. The issue still there and we couldn’t confirm what is the actual cause of it. Thanks

Hi Mahmoud,

have you found a way to fix the issue ?
Actually i’m struggling with the same problem

Hi @Mahmoud87, @phillxnet, @Flyer, @Hooverdan and @TheFox.
I have same problem, client Windows 7, rockstor 3.9.1-16

Trying to open the previous version and ended up with error “access denied”:

Can anyone please confirm rockstor version, on which this feature is actually working?