Cant create Samba share/export since upgrade to samba 4.6.2 (CentOS 7.4)

Brief description of the problem

Cant setup Samba export with any share.

Detailed step by step instructions to reproduce the problem

Since the Samba problem (rebase to centos 7.4) was fixed i cant enable/create samba exports/shares. As i’m trying to setup a export, choose an existing share and just hit enter, the GUI reports an error and doenst finish setup. The export doesnt get created…no traceback…no error logs in syslog

Web-UI screenshot

Error Traceback provided on the Web-UI

No Traceback

@g6094199 Could you say what Rockstor version you are using as a similar problem was fixed in:

via the following:
Hopefully that’s you’re issue, there is a screen grab of the same error being displayed after the same action is taken so looks promising.

Hope that helps.

oh sorry…i forgot

it the latest release with all yum updates, so its 3.9.1-13.

@g6094199 OK, so have you also refreshed your browser as the code that caused that issue runs in the browser and can still remain resident in it’s cache. We had a major but necessary backend change in 3.9.1-9 which caused this issue as there was a missed bit of code that was only brought in line (in the front end) with the backend in the referenced 3.9.1-11. So if the browser has not picked up the new version of the code (via caching) then you will still experience the issue.

Otherwise, without some logs, it’s difficult to work out what’s happening.

Let us know if you get any further, or find some more log entries.

He Phil!

THX, Yes it was the browser cache.I should restart my Linux desktop at least once a year :stuck_out_tongue:

@g6094199 Great; thanks for the update. Yes I’ve found that Chrome is particularly aggressive on the caching and will sometimes take 2 or 3 refreshes on a page before it fetches the ‘new code’ put in place by updates. Firefox is a little less persistent that way but I often find a refresh is required to pull in any updates / dev change. Also on Linux desktop.

Glad your sorted.

in fact i had less trouble with chromium, while there it worked out of the box, ff refused it a bit harder to load the new code…

@g6094199 OK, good to know. I’ll try some more next time I make a change on the browser code. We have a simple little bug fix coming up actually so I’ll try both after that. Cheers.