Can't log in after setup

This has happened twice now. I install Rockstor, log in, set up an Admin user and everything is fine. I can see and use the root pool on the install drive and can log into the webui, shutdown the system from the command line on the server itself, no issues. All that changes when I set up pools and shares on the other two drives. I run zypper refresh and update again, it installs acouple of files that require a reboot, so I reboot the system. Now I can log onto the server itself, but not the webui. Using the same passwords as before (and the same ones I use to log onto the server directly, the webui tells me that my credentials are invalid. Also, now if I try to shutdown the system from the command line on the server, it tells me that ‘shutdown’ is not a recognized command. WTH?

@noeman5 not that this helps to solve your basic problem of accessing the WebUI, but can you check at the cmd line

systemctl status rockstor to see whether it’s running in the first place?

For a command line shutdown using systemctl you actual would have to enter:
systemctl poweroff instead of using the shutdown command, this ensures a graceful exiting out of Rockstor and other loaded apps, etc.

same thing for the reboot, there you can use the systemctl reboot

if Rockstor shows as not running, you can scour the logs for some hints in this directory:
/opt/rockstor/var/log and use journalctl -xe to check for other possible reasons.

Finally, I assume your installation version is 4.6.1-0 on Leap 15.4?


Thanks for the reply Dan, yes, the server is up and running, I have been able to log into it using the password set up during installation and the admin name and password via the command line on the server itself, but for some reason not from the webUI. Weird.
As far as shutting down goes, I was using ‘shutdown -h now’ to shutdown, and ‘shutdown -r now’ to restart. Both seemed to provide an orderly shutdown process before the second update (when the system files were installed that required the reboot). I’ll try sysctl when I get home from work. Thanks again!

1 Like

Hi again Dan! When I got homen I used the systemctl command to shut the system down and it worked. When I restarted the system I checked it using the status operator and ensured it was up and running and tried logging into the webui again, still no luck. This time I tried the commands in the password reset window and after a little trial and error, was able to reset my Admin user (non-root) password and was able to vring up the dashboard on webui. Problem solved! (at least for now.)
Thanks for your help.