Can't mount ssd for cache disk

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

can’t mount ssd ( for cache )

Detailed step by step instructions to reproduce the problem

[write here]
Rockstor > STORAGE > Pools > Create Pool

name : cahce
raid configuration : single
compression : don’t enable compression.
mount options : noactime, rw, ssd
select disk : ssd 128GB ( ata-SanDisk )

Web-UI screenshot

Error Traceback provided on the Web-UI

Traceback (most recent call last): File "/opt/rockstor/eggs/gunicorn-0.16.1-py2.7.egg/gunicorn/workers/", line 34, in run client, addr = self.socket.accept() File "/usr/lib64/python2.7/", line 202, in accept sock, addr = self._sock.accept() error: [Errno 11] Resource temporarily unavailable

I change mount option
from : noatime, ssd, rw
to : noatime


@oldbell Hello there, and welcome the the Rockstor community forum.

I think the issue you had was to put spaces between the options: if you need more than one option (such as you got working) try no spaces, i.e.:


We should improve the error message there. I.e. see the space in front of “rw” in the brackets:
“mount option( rw) no allowed. …”
The message then goes on about checking for no whitespaces - that’s basically spaces or returns or the like.

Hope that helps. You can always change it in the Pool details page under Extra mount options.


While it is stated in the info text that no spaces should be used when entering the mount options, I created a github issue for this, in case there is time/capacity to address this at some point (after other, urgent priorities have been taken care of).