CIFS - "mount error(13): Permission denied" (UPDATE)

Trying to mount samba share to ubuntu server that is running in lxc container on Proxmox 4. Rockstor lives in its own VM. Everybody can ping everybody on the LAN. I have cifs-utils installed. I have a mixture of linux and windows on the network. I have an entry in /etc/fstab as follows:

// /mnt/cifs cifs username=XXXX,password=YYYYY,domain=WORKGROUP,iocharset=utf8,sec=ntlm 0 0

which is from ubuntu documentation and is reflected in a couple of tutorials I watched/read. I have also tried several variations of this. No mater what, I get, “mount error(13): Permission denied” in ubuntu server. Get same error with “sudo mount -t cifs…” at ~$. However, I can mount the share via “smbclient //server/share -U user%password”

my ubuntu laptop has no trouble, neither does my win desktop, just the sever. Hell I even have it shared to my Nexus.

any help with getting this share mounted would be greatly appreciate.


The problem is, THAT’S NOT HOW YOU DO IT IN LXC!

damn, 2 days wasted trying to do something that you can’t do. Evidently mounting a network drive to a lxc container is not that straight forward and way above this noobs head. There is only so far I wam willing to go down the rabbit hole.


Just make a regular KVM and everything seems to work right. Not 100% sure permissions aren’t wonky but I will figure that out later. Just happy I got the GD network share to mount. :fireworks::tada:

1 Like