Corrupted leaf, pool in read only mode

I need some help. ive recived messages about corrupted leaf and bad block on one of the disk. Ive try scrub option but it doesnt work (scrub fail to finish). The pool is mounted as read-only. Attaching the foto with the error.
What can i do to repair this pool? Please help me if U can (im linux newbie)

Hello @Dominik_Iwan,

You can try unmounting the pool and then run:

sudo btrfs check --repair /dev/sdc

Thanks, but when i`m trying to unmount the pool doing

umount /mnt2

i get message that this is unmounted, whe tryng to repair, the device is busy.
The pool is two disk (sdc, sdd)

@Dominik_Iwan and @vesper1978

Yes, the default in btrfs is to go read only upon errors found.

Excuse me for chipping in here but that advise should be reserved as a very last resort. It can do more harm than good. And as this pool (of which sdc is a member) is still mountable you should first consider retrieving what data you require prior to exercising any further repair scenarios. The following gives a nice run down of your repair options, in order:

“How to repair a broken/unmountable btrfs filesystem” section of the following page:


“/mnt2” is not a mount point but a root for a number of mount points. When dealing with the pool your mount point would be “/mnt2/pool-label” and the output from the following command would also be helpful to forum members able to help, if not only to see the label and structure (and possibly any drive missing status).

btrfs fi show

Hope that helps and thanks to @vesper1978 for helping out here. Much appreciated and I recognise that @Dominik_Iwan had already tried a scrub (as per the openSUSE referened doc) but there are, as indicated in that doc, several more things to try prior to the last ditch heavy hammer of ‘–repair’ which could leave the pools data irretrievable. Rockstor is currently weak, guidance wise, in this scenario but getting better all the time.

1 Like

Thx Philip for explanation and help
I will try all steps from link, mayby scrub on unmounted device will help
Will post my results

I`ve done all steps from the link without last but still get ro mount
Last one

btrfs check --repair

with shacking hand but it finaly works

Last question. How to mount pool with subvolumes? Do i have to mount all subvolumes one by one?

Thanks all for help. Now need to reinstall rockstor. I know it should be another topic but i cant get rockstor to install from iso 3.9.1. It always stuck on addon install and show debug window. Maybe some help with that too ? :smiley: