Couch Potato Rock-On

I just slapped this guy togeather but i had a thought when i was doing it. I remember reading in some docker documentation that you can send docker containers through other containers ie one that was a VPN. Just a thought i’ll work on it some more when i get time.

Disregard i have to fix one of the storage lines. i’ll repost it once i know i undorked it for good.

Sorry I realized my opening { got clipped off in the paste. it should work now.

CouchPotato is now available as a Rock-On. I am not a user personally, but if you are please test and report back any issues. The image used is form @weedv2 and colleagues!) and it should be solid.

1 Like

i can’t fully test it yet but i did notice that the website link is jacked up. you click it and it tries to send you to the ip of your box with the docker link at the end ie<></a>

edit: i looked at the others and notice sonarr is the same way.

I will look into it, same with sonarr rock-on. Bear with me, they are my first ones

Just installed the couchpotato rockon, the UI gives a connection refused, checked the logs and saw

“DEBUG [storageadmin.views.rockon_helpers:70] Attempted to remove a container(couchpotato). out: [’’] err: [‘Error response from daemon: no such id: couchpotato’, ‘Error: failed to remove containers: [couchpotato]’, ‘’] rc: 1.

Not sure if that’s any help but thought I’d post it here for you.

That is not a serious error. Note how it’s a DEBUG log? usually, non serious errors are logged with DEBUG.

It’s possible that the Rock-on is taking some time to get ready to serve connections. I remember seeing this when I tested and after 1-2 minutes, it was ready.

I have given it 30 minutes, still getting connection refused.

two options here:

  1. connect with http://ip-of-server:5050

  2. manually install json file which i wrote, before it was cleaned up:

Find couchpotato and rename it to couchpotato-test or something

tried the ip:5050 - nothing, i’ll attempt the json install when I get more time. Not sure why it’s not starting.

I grabbed it from the git repo you listed, still no joy. Can you tell me where it would dump logs so I can attempt to troubleshoot? I’ve not really used docker that much.


Did a reinstall of rockstor and couchpotato. It works as intended.

Link issue I have figured out, will notify @suman about this, and have repo updated.
It is in line 50 of both sonarr and couchpotato rockon the following:

“website”: “”,

correct should be: “website”: “”,

minor mistake, but should be corrected.

@Kedearian: Do you have a firewall or something? because orange button “Couchpotato UI” Does work as intended. Note: I am on a LAN behind firewalls. For remote access one would need port forward in router/firewall.

Hey @bug11! Thanks for the correction. I’ve just updated. Please confirm when you can.

I am not a user of Sonarr or Couchpotato, so it would be super if you assume the “maintainer” hat on these :slight_smile:

Sure. I can maintain the rock-ons I create if needed, no problem.


Hi, just wanted to pile my question on this thread. Installed Couch potato, everything work smooth BUT it seem to be unable to download anything. The “blackhole” is enabled in setting by default, but there is a connection error when tested and connecting to docker terminal and manually searching for anything blackhole related returns nothing


There should not be any connection if you use “black hole” setting. Couchpotato will the download torrent/nzb file into said folder, and then your downloader software should be set to automatically add torrent/nzb into download que when new file appears in “black hole” folder.

To further assist, please provide some information about your setup (downloader and plan for downloading).

Or, try to follow these steps, works like a charm (its how I set up everything)

Thanks for your feedback, I’ve managed to get it working with

  • transmission (that I’ve already had running but ultimately I wanted to get rid of it because it’s cr** ) - trick here was to put a rockstor install hostname into a hostname field, localhost and local loop address is bound to never work (
  • deluge, which is far more refined than transmissions - but this one took me a best part of a day to configure :confused: trick here is and I’ll have to do a write up somewhere that in deluge you need -> connect to docker image constole (you know "docker exec -it #@@#%@#_number_of_deluge_docker_from_ps bash) -> edit /config/auth and add a new user there (lets call it couchpotato), give some sort of password and level of preferably 5 -> configure daemon to allow remote connections in deluge gui -> in couch potato confogure deluge with your newly created username and password -> configure paths correctly because deluge by default writes to /root/ (because the newly created user ABC from rockon does not contain default home, so deluge get’s really confused) -> configure same paths in couch potato as well … VERY SIMPLE !