Deluge not using correct Download Storage share

When I install the Deluge Rock-on the Wizard asks me to select the Config Storage and Download Storage shares. It appears that no matter which share on my system I select, the Download Storage location becomes a sub-directory within the Config Storage share that I select in the Wizard.

The install works for downloading, but I don’t want to have to share all of the Deluge Config files across my network share so that others can access the downloaded files. Can anyone suggest a work around?

I’ve experienced the same error. The download share is (correctly) mapped under the /download directory, but Deluge is not configured to save its downloads to the correct location.

A workaround is to configure the download locations manually via the web interface:

Go to: Preferences -> Downloads

Download to: "/downloads/incomplete"
Move completed to: “/downloads/completed”

(completed/incomplete folders are optional of course)

Ideally this should be fixed in the linuxserver/deluge docker image.


Hi David, thanks for the reply.

I have tried your recommended workaround but still get an error when trying to download a torrent.

I have tried the following and none of these seem to work. I have manually created the folders in the shared folder as well just in case. Do you have any other ideas?






Maybe in your case the error is caused by something else. Can you confirm all paths are in lower case? (e.g. '/downloads/ is not ‘/Downloads’)

What is the exact error you’re receiving?

Yes I can confirm that it is all lower case.

I noticed in this reply you used apostrophes, should I be using these?

I do not have them in my working config.

What kind of error do you get from Deluge?

Hi David, the error is just the progress error in Deluge. The torrent begins to download fine but then errors.

If I set the Config Storage and Download Storage location to the same share everything is fine and the torrent downloads to the shared folder with all of the other config files.

FYI, I get the following:

Total Size:228.0 MiB

of files:7

Comment:CentOS 6.8 x86_64 netinstall ISO
Status:Permission denied: /downloads/CentOS-6.8-x86_64-netinstall/CentOS-6.8-x86_64-netinstall.iso

It says permission error, probably something’s wrong with your permissions.

You provided an UID and GID while installing the Deluge rockon / docker image. Make sure this user has write permissions on the download share.

You can configure this at Storage -> Shares. Click on a share. Under the tab ‘access control’ you can edit the permissions applied to this share.

I hope this will help you :slight_smile:


Thanks David for your help. Yes this was the problem. Because the share was created using root user I needed to make the Share writable to Other. Haven’t figured out the security issues with this yet but it did fix the problem.

Can’t say thank you enough I was just about to install OMV. Now to see if I can install a browser based file manager on Rockstor.

1 Like

Glad to hear everything is working for you, happy to help!

I have created a group called ‘homeshare’ and a user ‘media’ that belongs to the ‘homeshare’ group. Deluge (and Sonarr, Couchpotato etc…) are running as this user. In this case you don’t need to give write permissions to ‘other’, only to the group.

But, in case it’s just for home and you trust your user I wouldn’t worry to much about it.


This was my problem. I had permissions setup properly, but the preferences were misconfigured for /root/Downloads instead of /downloads.