Does Emby DLNA actually work on Rockstor?

I read the documentation on Emby’s site and decided to give it a go. I’m not realy into watching series / movies all that often, but it would be nice to host my own video’s somewhere, so I actually watch them without sitting down at my Archive PC.

So I bothered to grab the official Rock-on and configure it, which seems to work fine. Added some media to it, enabled DLNA, tried it on my browser and all seems fine. Play-to shows both my Receiver and my Sony Blu-ray player which has media server support as well as MiraCast for video. (The AVR only does Audio DLNA & MiraCast music)

The thing is, while Emby seems to find my devices, and playing to them from DLNA-request is enabled, it doesn’t actually work. Neither does the Blu-Ray player detect the Emby Service. While it does find others (other NAS, DLNA service on the Modem etc) I bothered to disable all other DLNA servers to free up ports, to no avail.

Network description
So I found that DLNA actually only works on a single subnet. I do have two “routers” but I have them on one subnet, and a home-one at that (10.0.0.x) The second router does not use the WAN port and has DHCP disabled. The gateway resides at and the secondary router (well, more unmanaged switch + wifi) at The Rock-stor box is hooked up to the second router and has IP Next to it, a PC at, which can actually be found on DLNA, if the Windows 10 service wasn’t so bad… Anyway, it gets detected, you can browse it, runs into errors when you actually try to serve a file.
Connecting my phone to the 2nd routers Wifi (5Ghz only, so there’s no confusion since it’s name differently) doesn’t make a difference, cannot find the DLNA service.


(I) Does Emby DLNA actually work for anyone?

I tried adding port forwarding / triggering as well, but I might have been doing it wrong. (II) Should I bother with TCP ports for DLNA on the same Subnet with UPnP enabled? There’s also a thing called Protocol Independant Multi-cast (Sparse or Dense mode) but it seem it is not supported by either my Router (unmanaged switch) or Modem. (III)Would that (PIM) be required?

(IV) Would it help to split off my Rockstor from the 2nd Router and hook it up to a second (dumb) switch? (I would have to get one specifically to test this, all the ones I have are in use)

(V) Did I perhaps miss a setting, a docker port setting perhaps, an hidden Emby config, UID rights settings, etc?

Many thanks for sticking with me through this issue, looking forward to the replies!

I am afraid it does seem related to your configuration as I run the Emby rock-on and can use the DLNA without problem. I do have a very simple configuration as I only have one router and subnet in my network.

I didn’t have to enable anything in particular to make this work in my case, and I stayed with the default Emby configuration. I use to stream to my DLNA-capable TV in one room, and to my Pi2 in another room, both from the Emby Android app. The only problem I had to “make it work” was simply because I was expecting it to work as soon as my DLNA device (TV) was selected in the Play-To option, while it actually only works once the video starts playing.

I’m sorry for not offering you a solution to your problem, but at least I can confirm that this feature works with the Rockstor Rock-on.

Let me know if you’d like more information…


Good to know that people have had success with Emby. Totally forgot they have a mobile application as wel. That seems to work fine on either of the WLAN’s as well, so that doesn’t seem to be the problem.

But on neither my TV, Blu-ray player or Receiver I have the option to install applications, so that will not help me out.

One thing I forgot to mention though is that Sony’s BRP-6700 does “detect” a network source at (aka the 2nd Router) that is unavailable / unaccessable. Gives some vague hint about firewalls or security. I guess perhaps the ports are not forwarded right perhaps? (That would mean that UPnP doesn’t do a propper job I guess)

Just to say that me too I have no success with LG TV set, TV discovered Emby dlna server but no way to find medias. After trying Plex DLNA same behaviour. Whith my laptop in the same network things look fine.