Dracut-initiqueue after install

I always get this error after installing on a USB drive
Install source from USB
Install source from DVD
Samsung FIT 32gb thumb drive
Kinkston usb 3.0 thumbdrive
installed with a connected hdd
Installed with no hdd connected
moved the usb thumbdrive trough the usb ports

No luck. Any clues from the forum?

Sorry not much of a solution here, but there’s a USB related problem that’s kernel related. See this issue. Apparently fixed in 4.5 kernel according to @roweryan

Thanks Suman,
After installing to a new kinkston 16gb thumb drive I have successfully started working in Rockstor. I’m now a happy subscriber.
Thanks fro the prompt reply, João

1 Like

Same issue. I tried another USB stick and still getting the same error.


AMD Athlon 5350
ASRock Micro AM1H-ITX
2 WD Red 4TB
Rockstor: 3.8-13

@William212 Welcome to the Rockstor community. I’m assuming here that you successfully installed but then got the same errors as the original poster. I have seen something very similar myself of late when trying to boot a Rockstor system that was installed on a Sandisk Extreme 32GB and am pretty sure it’s down to the kernel issue that @suman referenced earlier in this thread. There is little that can be done about this until we move to the newer 4.5 or newer kernel so you may just have to try you luck with a different USB device again or port or better still use a straight sata port for the time being. I switched back to using an msata to pci adapter and no longer see this. I also after a few updates got frequent kernel panics during boot.

Hope that helps and let us know how you get on. The project is about to start a new series of testing channel updates so the likely hood of a kernel version upgrade has increased.

1 Like

Thanks for the note!

Were I to add a SATA drive to the build and boot from there, would I be able to eventually migrate to a USB when the new kernel is released?

My box can only hold 3 HDDs (CoolMaster Elite 110) and I was planning on having a 2 RAID drives and single JBOD. I’d hold back on the JBOD if in the future I would be able to boot off a USB.

Wound up squeezing in an old 250GB drive into the box and installing Rockstor on it. Worked.

But long term, it’s not the best solution. Will I be able to reinstall Rockstor on a new boot drive and still be able to access my pools? I believe the answer is yes.

All your Pools, Shares and Snapshots on non-OS drive(s) can be imported after a new install as explained in the docs.