Emergency mode after loading Rockstor-Leap15.6-generic.raw

Hi,

I tried to install Rockstor 15.6 and 15.5 on my Shuttle XPC cube SH310R4 v2 several times now. Unfortunately, I always boot into emergency mode (maintenance mode) after 100% of the .raw is loaded.

On controlc I have some output of rdsosreport.txt, journalctl -b. The lsblk output you can see below.

NAME    MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
sda       8:0    0   9.1T  0 disk 
sdb       8:16   0   9.1T  0 disk 
sdc       8:32   1 232.9G  0 disk 
|-sdc1    8:33   1     2M  0 part 
|-sdc2    8:34   1    64M  0 part 
|-sdc3    8:35   1     2G  0 part 
`-sdc4    8:36   1 230.8G  0 part 
sdd       8:48   1 111.8G  0 disk 
|-sdd1    8:49   1  79.9G  0 part 
|-sdd2    8:50   1     1K  0 part 
`-sdd5    8:53   1  31.9G  0 part 
sde       8:64   1 223.6G  0 disk 
sdf       8:80   1 223.6G  0 disk 
sdg       8:96   1  14.9G  0 disk 
`-sdg1    8:97   1  14.9G  0 part 
sdh       8:112  1  58.6G  0 disk 
|-sdh1    8:113  1 787.3M  0 part 
`-sdh2    8:114  1    20M  0 part 
sdi       8:128  1 977.5M  0 disk 
`-sdi1    8:129  1 976.4M  0 part /tmp/usb
nvme0n1 259:0    0   1.8T  0 disk 

Hope to hear back from you soon.

Regards,
sevi-kun

@sevi-kun Welcome to the Rockstor community forum.
Re:

From: Shuttle Global || SH310R4 V2 - Specifications
specifications tab this is seemingly a regular X86_64 system so it is expected to boot OK. Could it be that this is some kind of secure boot UEFI think? Can you turn such things off in the bios settings and see if that helps. You may well have to re-install there-after for the installer to react appropriately.

You could also try the Tumbleweed installer, it may be this system has need of something that has yet to make it way to the regular Leaps.

Hope that helps. And do have a play with the bios settings: keeping note of what you change.

2 Likes

Hey,

I actually tested all images in legacy boot mode. So that’s not the issue.

But after figgeling around with my setup, I remembered that the disk I’m trying to install on is connected via an PCIe SATA card. Seems like OpenSUSE had issues booting from this card.

So connecting that disk to the motherboard directly solved my issue.

Thank you for your support.

Regards

3 Likes