Fail to connect to webUI after black out

I have been using Rockstor as office NAS for few months. Things are good until last Friday, we had a blackout, after that I cannot connect to Rockstor, the Ethernet port on PC showing 1 orange light and 1 green light. Pinging to the IP return “unreachable”
Is there any solution to solve the issue or recover the data? I tried to connect the hard disk to other computer but cannot file to stored data.

@dhviet welcome to the Rockstor community.

Sorry to hear about your troubles due to the blackout. For future cases, it would probably a good idea to invest in an UPS to ensure a graceful shutdown.

Do you have a monitor/keyboard connected to the server, or can you do that to see whether another reboot gives you some indication on what might be going on? That might be the first choice to determine what’s not working, and there might be some “simple” fixes.

If that doesn’t work out, you can go the route of reinstall of Rockstor.

In general, especially if at some point recently you took a backup of the Rockstor settings onto another device, you could reinstall Rockstor on the OS drive and reimport the pool(s) that you have set up prior.

You can take a look at this:

and here for the reimport of pools:

The reinstall guide above needs to be reworked in terms of details and screenshots. Before you do a reinstall, you probably want to disconnect your data disks first, do the wipe/reinstall on your OS disk, shut the system down after successful install, reconnect the data disks and then perform the pool import back into Rockstor (and if you have the configuration backup, apply that one as well).

Of course, at this time it won’t be clear on whether you have some degradation on your data disks, it will depend a lot on what “action” was occurring when the blackout happened. If the disks were idle, the likelihood of the data being fully intact is fairly high vs. if there was a lot of writing of data going on…

as @GeoffA always emphasizes, have good backups of your data …


I couldn’t possibly comment… :slight_smile:

1 Like

Thanh you very much for your help. After connecting monitor and reboot I can see that the IP address have changed. Then I connect to web UI and change the IP address back (switch to static). But now I cannot connect to my file from windows machines, it work fine with linux machines. Do you have any idea to solve it?

Update: after reboot, all windows PC work fine with Rockstor.


Glad to hear it worked out!

I usually drive the fixed IPs via the router, rather than on the machines itself, I feel it makes it easier to manage numerous devices that way (especially when working with various subnets on a more extensive network), but obviously either way works.