Failed to join domain: failed to find DC for domain


I’ve just started experimenting with Rockstor…and the very first thing I tried to do is join my Samba domain.

When I entered the active directory details, saved them and tried to activate the service, I am greeted with:

CommandException: Error running a command. cmd = /usr/bin/net ads join -U domainadmin. rc = 255. stdout = ["Enter domainadmin's password:", 'Failed to join domain: failed to find DC for domain MYDOMAIN', '']. stderr = ['']

The password for domainadmin is correct and the FQDN resolves in DNS. I used the very same details to successfully enrol another machine without issue. Not sure this is expected, but I noticed the “MYDOMAIN” in the error is not a FQDN, I’d have expected it to be “MYDOMAIN.CO.UK” (as entered in the settings).

Domain/Realm Name:
Administrator Username: domainadmin
Idmap Range: 10000 - 9999999999 (my UID/GID’s are 10 digits)

Enable RFC2307 is unchecked

Any advice on something I need to tweak to make this work?!

There are some YUM updates that need to be installed, but every time I click “OK” to update the packages, nothing seems to happen and the update notification re-appears. (I’m using Safari) :-/

Thanks in advance from anyone that can help.

Hi @Cloggs,

That error happens when the DC for your domain is not able to be resolved via DNS.

Can you login to the shell as root and try the following command:

net ads join -U <domain admin> -S <FQDN of DC>

Hey @vesper1978,

Thanks for the reply. I’d reached the same conclusion and was about to try that. What I did first was:

yum update

Once I did that, I immediately tried again from the GUI and it worked! As stated in my previous post, there were quite a few pending package updates that I couldn’t install from the GUI (clicked ‘OK’ to confirm update and nothing happened). Now I think about it, it could be that I was using Safari, but then it’s not caused any issues in any other areas of the GUI…