Failed to mount sysroot

Hi guys

I’m searching for help rescuing my rockstor install. I was running the system without major problems for close to three years by now.
Here some details about the current problem:
Through the WebGUI I downloaded some new packages (blinking “wifi” sign). I restarted, the updates were offered again, I tried again, restarted again. Might not have anything to do with anything, but just in case.
I then tried to get a new Rock-On running (Handbrake), which seemed to work.
Suddenly, no access anymore to the Server, neither the WebGUI nor any Rock-Ons like Plex or Sonarr. The WebGUI showed some message like “rockstor not reachable”, so the server wasn’t “inexistent”.
I gave it about 24h, then pulled the plug (not a good idea, I know)
After a new start I got the message below:

'"Entering emergency mode. Exit the shell to continue."
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/rdsosreport.txt" to a usb stick or
/boot after mounting them and attach it to a bug report.`

I searched a little and also got the message below:

failed to mount sysroot

I tried “fsck” and “xfs_repair -v -L /dev/dm-0”, which were both not successfull (path different in rockstor than CentOS?), but both commands were unknown (do I first have to navigate somewhere?)

I’m using a USB-drive for the OS (not ideal, I know)
First I tried to do the “troubleshooting -> rescue installation” with both the old OS-drive and the new bootable inserted, as well as with only the new one. Got the same error as above.
I tried reinstalling on a new USB-Drive, hoping to restore the data from the existing pool, but didn’t get past the “installation selection”. It was just greyed out, nothing happened when clicking on it.
I tried that with the only the bootable drive inserted and also with the bootable drive and a blank drive inserted. Still the same issue.
The HDDs were connected the whole time, could that be the issue?

I don’t know what else to try, do you have any tips? Also I will try to export some logs, if you can tell me which ones could offer some information.

Thanks for reading all this and trying to help me, it’s much appreciated!

@schoschi12 Welcome to the Rockstor community.

This was likely because the intended system drive, the prior one I’m assuming, needed to be clear first. See our: “Reinstalling Rockstor” doc section:

You could try building our intended next “Built on openSUSE” Stable release installer, currently at RC 4 (AD and LDAP are still broken but most of the other functions are looking to be fine):

The ‘how to’ doc for for this installer, once build, is here:

And if all is well, once it’s installed and up and running you can just import your prior pool. Best during an install to completely disconnect data drives as then there is no chance of acidentally selecting the wrong drive as the intended system drive.

Hope that helps.


@phillxnet: Thanks for your inputs and sorry for only replying now. I’m not quiet there yet, but I think I can work things out on my own.
For anyone else observing simlar behaviour:
The main issue was that the usb-system-drive was bricked. It behaved as if only write-protected, and there was no way around it.
The next issue were my other two USB-Drives, on which I tried to install rockstor. They both didn’t have a serial number and thus couldn’t be selected as a system drive.
Now on to my next error: I ordered an M.2 SATA SSD. Installing rockstor worked perfectly well, but one of my data drives didn’t show up. Of course importing the existing pool with a drive missing didn’t work. Since my motherboard only has 6 SATA lanes, one connector was deactivated when plugging in a SATA SSD.
I will now replace the M.2 SSD with an NVMe one, so all 6 SATA lanes are available for the data drives.

Thanks for your help.


Ok, bad news. In the installation GUI, the NVMe SSD is not recognized (“Installation Destination: Failed to save storage configuration…”).
In the BIOS and boot menu, the NVMe SSD shows up. Now also all the 6 SATA HDDs show up.

I played with some BIOS settings, but nothing seems to work.

Any ideas, on how to install Rockstor on the NVMe SSD? I could try to install it on another motherboard, then plug the SSD back into the NAS and try to boot from it, then loading the existing pool. Does that make sense? In any case, why doesn’t it work the same way as with the SATA SSD?

Thanks again for the help.

@schoschi12 Re:

Yes it does. A Rockstor install is completely transportable. It will however pick up it’s Appliance ID from the original ‘donor’ install machine. But you can always change your subscription over via Appman if that is an issue.

Are you reporting your findings re Rockstor 4 or are you using the older CentOS based installer. The latter is graphical while the former/newer 4 variant is a text only install that is far simpler. This is the newer Rockstor 4 installer:

Thanks for the update and let us know how you get on.

1 Like

I finally got it to work. Previously I was only working with the CentOS based installer, but with the openSUSE based installer, I had none of the previous issues and I could now successfully mount the old pool.

Thank you very much for the continued support.

@schoschi12 Glad your now sorted and thanks for the update.

And well done on getting the new installer build and deployed. Our newer ‘Built on openSUSE’ Leap 15.2 base has all sorted sorts of improvements over our rather neglected kernel maintenance and older CentOS 7 base. And given the more recent news with regards to newer versions of CentOS it looks like we are in a better place going forward.

Thanks for the feedback. Still some hiccups/obvious bugs in the new endeavour but we are getting there.