Fatal error GUI addons configuration step (post install 3.9.1.iso) , text.inst works!

Hello folks, I’m Babiz from Dolomiti.
I just to try installing Rockstor on external usb drive for testing purposes, and the setup fail after installing packages > installing bootloader (on /dev/sdb) > running post-installation scripts > configuring addons.

So I’ll try to reboot into Rockstor, but is still unconfigured at all because I not see url for login to webui after Rockstor bottup complete and prompt for login user account.

Well I’d like to know if is possible to resume setup from this condition (for example to launch anaconda or one kind of python script) …or I’ll better to give up and retry to install Rockston alone over /dev/sda?

Thanks in advance for all folk will to reply me.

Attach error logfile anaconda-tb-G1Mcb9 below:

anaconda exception report
Traceback (most recent call first):
File “/usr/share/anaconda/addons/org_fedora_oscap/common.py”, line 230, in run_oscap_remediate
raise OSCAPaddonError(msg)
File “/usr/share/anaconda/addons/org_fedora_oscap/ks/oscap.py”, line 525, in execute
self.postinst_tailoring_path, chroot=getSysroot())
File “/usr/lib64/python2.7/site-packages/pyanaconda/addons.py”, line 84, in execute
v.execute(storage, ksdata, instClass, users)
File “/usr/lib64/python2.7/site-packages/pyanaconda/install.py”, line 104, in doConfiguration
ksdata.addons.execute(storage, ksdata, instClass, u)
File “/usr/lib64/python2.7/threading.py”, line 764, in run
self.__target(*self.__args, **self.__kwargs)
File “/usr/lib64/python2.7/site-packages/pyanaconda/threads.py”, line 227, in run
threading.Thread.run(self, *args, **kwargs)
OSCAPaddonError: Content evaluation and remediation with the oscap tool failed: WARNING: Skipping http://www.redhat.com/security/data/oval/Red_Hat_Enterprise_Linux_7.xml file which is referenced from XCCDF content
WARNING: Skipping http://www.redhat.com/security/data/oval/Red_Hat_Enterprise_Linux_7.xml file which is referenced from XCCDF content


Complete log file is available for download at gdrive link :slight_smile:

Hello again, now I writing for yours knowledge, I’ll do right installation with “text.install” switch at bootloader prompt and on single hdd connected at main ich7 controller (sda) of my laptop.
Later installation fully complete I’ll able to run Rockstor from external usb controller (I detach hdd from main controller and attach to an sata to usb controller).

Well bootup, and proceed to configuring somethingh like shares nfs, samba and plex addons, all work perfectly out of a box I’m excepted.

BUT… some kind of stuff not propely configured under post installation scripts .
I set following options in setup (text mode) like:

localization (Italian)
keyboard layout (IT Winkeys) even “env” variable LANG=it_IT.utf8 is correctly set but no effect
This stuff still in english after regular booting of Rockstor.

The sadly thing is , after I rebooted system (shutdown command tought SSH)
I lose all access to Rockstor box!

I see only two port open by nmap scan:
111/tcp open rpcbind
2049/tcp open nfs

WELL ! Ahah :smiley: after see this, I go to read about issue and fond some post on this forum for this kind of problem, seems related to POSTGRESQL database, my installation also trow many errors related to it.

Results impossible to restore https or ssh access for my basic knowdledge of centos , and I’ll give up and try to reinstall again now.

This is VERY annoing :frowning: I’m sad enough.
Acutally I’m try lastest build downloaded from sourceforge and verified by inline “testing & install” feature at bootup prompt.

Hope will more luck to me netx time… so related this issue maybe gonna I activate the “Testing update channel” ?? I don’t know.

Ok my last try fail once more time :frowning: Just installed with text mode on another pc desktop foxconn motherboard intel ich7 pentium with one sda for os and other two hdd in pool, after configuring first account and activate rock-ons and setup pool all done correctly even try to reboot.

At time to install plex and enable one samba export, after rebooting system (from webUI) Rockstor hangs at all, only tcp port 111 is opened, ssh and https still inacessible / deactivated.

I’m not applied any kind of upgrade, the release is still 3.9.1 and impossible to get working whit it!

So I do another (last) try with oldest release like 3.8.16 and hope to see more stable release or I’ll give up Rockstor and go to other nas distro.

Well folks, same as 3.9.1 , the 3.8.16 release fail to install with gui, same error for configuring addons step (post installation script). In addition text installation also fail, This release I guess not support “text.inst” command at bootloader prompt.

Now I’ll go ahead with OpenMediaVault distro, looks more stable for my needs, installation and configuration without hassle over the top!

In this lasts days nobody reply me for advice of any kind, Strange thing I’m alone with installation problem? I’m sorry about this.


I will omit a lot of frustration and other things that went wrong with my setup a few times, but maybe this helps for you as well: try without a security policy. In my case that worked and the setup didn’t fail with that error…

(I was trying with the default security policy and it would fail.)