First test install and a few unpleasent surprises -- given I am a Noob -- help please

I have installed Rockstor on a older Dell PC.

Background about me – Not a Linux user … mostly Win10 user. But building a NAS with 12-20 drives and would love to make Rockstor as the primary NAS device. Want to put together a 2-disk failure tolerance build. Please be kind! Currently running xpenology and thinking about moving to Rockstor … any help will be most welcome. Thx!

  1. When installing unit, I installed on a USB stick and no HDD.
  2. After setting up all the basics - Added a HDD

Problem-01: Unable to see the added HDD!!! Rescanning from the GUI does not seem to work. Any thoughts on how this can be fixed?

Problem-02: Got a error message, what does this mean? -Rebooted system and the error message is no more!!!

Problem-03: PARTIALLY SOLVED – Trying to launch shell from WebGUI and the shell is not launching. OK - figured out what is wrong. The Mgmt IP: field must be populated for this function to work. Now I am able to launch the shell. But unable to connect. Trying to reset root password. Maybe it will work then?

EDIT-1: Edited to change status after further testing.
EDIT-2: Partially solved as I can launch the Shell but still cannot start the session.