Free Unlimited Cloud Backup for Rockstor, already available on CentOS. Little help?

I’m an avid Symform user and have had a lot of success with them on my other NAS devices. I noticed that they have a Linux package already on their site for CentOS, but nobody has posted about using it. I’m not a fan of trusting all of my backups to one device, so every NAS gets replicated to the cloud for off-site backup. Since there isn’t any option for this in Rockstor yet, I thought maybe I could get Symform up and running relatively quickly and start deploying Rockstor boxes.

I’m going to build my first Rockstor box in the coming days and try to install Symform as a test. My questions are:
(1) Any suggestions about what the best way to do this is?
(2) Are there packages missing from Rockstor that are usually included in CentOS that might generate an error?
(3) What about permissions? Symform is constantly reading/writing and needs proper permissions to work on other NAS boxes. Might this be an issue with Rockstor?
(4) Would this be done as a Rock-on, or some other way?

I’m not a total noob, but I am a novice when it comes to Linux CL for sure. Any help is very much appreciated. I think the whole community can benefit from free off-site backup =)

If this build works out, I will be subscribing to the “stable” release channel to support the project. Really excited about the work happening here. Keep up the good work, guys!

1 Like

@Learning2NAS, welcome to Rockstor community!

I am not a Symform user, but after reading about it, it seems like a good fit as a Rock-on. I see that there is already a docker image for it. I have to say that I am running behind on planned Rock-on changes, but once they are in place, it should be easy to deploy docker images like these as a Rock-on. But I am getting ahead of myself here.

To answer your second question, you shouldn’t have any troubles treating Rockstor as a regular CentOS system. However, the kernel is not the default CentOS one. I doubt that would be a problem for Symform though.

I don’t have a simple answer for (3). You should experiment and let me know if there are any issues. We’ll sort them out.

Most important of all, I think your proposal is great. Please do pursue your ideas and keep us posted. I’d be happy to help and I think so would be the community at large!

1 Like

Tested on the current release of Rockstor and everything seems to be working.

Symform installed without issue, although I had to do it from CLI. In the future it would be great to see it as a click-to-install Rock-On like Plex because some users don’t don’t know how to use CLI. There is, as you noted, already a docker image for Symform so when the next milestone is complete, maybe Symform can just be added to the Rock-on list using its docker image?

After I installed it using yum (pulled from the URL on their website using yum -ivl http://URL), I configured it through the default port ( It began by verifying that my local data matched the data already saved to their storage cloud. Usually, it would then move on to sync any newly added data, but the service hung after the verification process finished. If anyone else experiences this, all you have to do is run “/opt/symform/ restart” as root and the process will begin working again.

So, the good news is everything worked. Easy install, easy to configure, free backup :slight_smile: The bad news is that (1) it had to be done by CLI (2) it got stuck for some reason, but a reboot will probably resolve that issue just as well as running that root command did.

I’m currently able to sync/upload to the cloud with Rockstor, and I’ll be testing my ability to contribute space from my Rockstor machine in the coming days. I will update once I can confirm that I am able to donate space. That is, afterall, one of the most important pieces of this puzzle.

Thanks for a great product and helpful reply, @suman.

1 Like

One thing I forgot:

When I was configuring which folders I wanted to backup, I had to dig a bit to figure out which one was most appropriate to point Symform to. For example, I have a share called Backup on my NAS that I wanted to copy to the cloud. I was able to find a folder called Backup in two places in the file system. I originally selected one in /Export/Backup, but after installing another Rock-On and checking to see what folders it used, I decided to switch my backup pointer to /mnt2/Backup to match the other Rock-On (which was looking in /mnt2/ as well for data it wanted to pull).

Is one of these locations more correct than the other?

I suggest choosing /mnt2 locations over /export ones.

1 Like

Well this is certainly an interesting concept.

Yup. The only downside that I can see right now is that they don’t offer support for using your own encryption keys. However, I’ve been in touch with one of the guys who works for them and he said they are working through a super long release cycle right now. The next release will be a total rework of the concept, designed to include all of the most heavily requested features from their forum (private encryption keys is there, among other things).

I wasn’t able to get any specifics on the launch date for the revamped Symform, but I think that problem will be remedied when they do the update. In the meanwhile, if you have some non-sensitive data that you want to test with, give it a go!


An update for anyone following this thread:

My RS filesystem went down several days ago and I haven’t been able to get it back up yet. Everything appeared to be working correctly prior to the crash, though, so if you’re interested in Symform feel free to give it a try.

I’ll be down for awhile until I can figure out what this BTRFS error is all about.

Let us know if there’s anything we can do to get you going again!

Hey Suman,

I’ve been wanting to learn docker anyways, would you be accepting pullreqs for rock-ons from a docker newbie?

I’ll definately look into Symform as well, but will start out with CouchPotato and SickRage, as thats currently on my Synology that I want to replace with a new 8hdd/2ssd rockstor NAS

I appreciate your willingness to help. I’m just held up because of life. When the holidays come around I’ll get back to troubleshooting my busted array. I have faith that it will come back online with a little bit of trial-and-error because I’ve found other users who’ve experienced the same issue.

Symform, however, was not the cause of my array going down :slight_smile: That worked well.

If you are able to work on a Symform docker, rather than doing this as a background install as I did, I would love to give it a try.

I’ve tested the Docker image that’s posted right now (the one @Suman referenced above) and it does not appear to be functional/complete. I don’t know a lot about Docker, but I involved three guys who build Dockers and they confirmed that it was non-functional. We’ll have to start over if we want to get one working.

This might be old news, but in case you just got to the bottom of this discussion like and did and are excited to try this out. Symform shut down on July 31, 2016.