GitLab Community Edition Can't login after install

Tried using the default credentials supplied in the info on the Rockon page but always gives invalid login.
What am I missing and there are literally no instructions about the install, access or config.

@nickm324 Welcome to the Rockstor community forum.

We have non of our own, as there has yet to be any contributed to our docs repository:

And we have the GitLab Rock-on in our following there:

Rock-ons without write-ups: Rock-ons (Docker Plugins) — Rockstor documentation

But post a doc contribution it could appear in our:

Rock-ons with write-ups: Rock-ons (Docker Plugins) — Rockstor documentation

However our Rock-ons are in no way ‘special’: and always link to the docker container used. Rock-ons are just easy-install wrappers around docker images:

And in the case of GitLab we use the official CE (Community Edition) image:

from: rockon-registry/gitlab-rc.json at 34fad04cbeb609f2f6910a0717f2ed40870c70a1 · rockstor/rockon-registry · GitHub

Based on the official docker image:

So all upstream info/documentation is equally relevant to a Rock-on instantiation, as it is any other docker based GitLab install. Within the limits of our chosen use of that image: which usually boils down to the options presented such as ports and volumes.

Hope that help, if only with some context. And if you find we have a bug in our implementation of that Rock-on/docker-wrapper, then let us know; either here or by an issue/PR in our rockon-registry GitHub repo.

If anyone else has had recent experience in setting up our GitLab Rock-on do please contribute to this issue. I’ve not tried it myself for quite some time now.

Maybe our “more info” in the Rock-on here:

in in need of updating. I.e. maybe upstream has now changed these defaults or modified how they handle the initial login.


With all that being said, I reviewed the documentation on Git hub and I used the default supplied credentials and they failed. So, there must be some custom configuration to this implementation.
This is from the info icon in the Rockon details screen. These credentials do not work. I am researching how to get past this issue and if I figure out a solution I will post it back here for others.


@nickm324 I’ve just had a quick look at upstream docs:

Take a look at the following: Install GitLab by using Docker | GitLab

There is a section there that reads:

… sign in with the username root and the password from the following command:

sudo docker exec -it gitlab grep 'Password:' /etc/gitlab/initial_root_password

The password file is automatically deleted in the first container restart after 24 hours.

If this works for you, (may required a clean Rock-on install due to that 24 hour thing), we can change our more_info guide to bring it in line with upstream again. If this is in fact now the ‘method’.

Thanks for your report on this by the way. I had meant to mention this previously.

Hope that helps.