Got a few Services Running on Rockstor (Dropbox, Pi-hole, Plexrequests, etc)

Tested your plexrequests rockon. Works wonderfully! I uninstalled my version and removed it from my how-to. I added a comment to the pull request confirming it works as well.

As far as the pi-hole goes, I will dig through my git repo for my best version of the json file and post it.

I have pi-hole ready for testing also. It still needs some work i think but could be good to have someone else giving input also. Don’t really like the dependency to port 80 but perhaps a rockstor developer can say if it’s ok.
Will wait until the plex requests are merged before uploading to me github fork.

For pi-hole you can just checkout a new branch in your fork of rockon-registry like this and can even push just that branch back to the master.

git checkout -b pi-hole

I added a method to use exiftool to automatically sort photos that have proper datetimeoriginals in their exif data.

I created the branch and uploaded the .json
Didn’t think i would actually start making multiple pull requests :slight_smile:

This .json is a bit of WIP and needs some testing. But will start and do it’s job for me.

How would one go about installing this (pi-hole), if I wanted to test it?

Add-blocking this way seems so straight forward :slight_smile:

Well you need to first add the file into director using SSH.

Login with SSH.
Got to directory “/opt/rockstor/rockons-metastore/”

  • If the directory does not exist… create it

Download the file into this directory using curl or how ever you want to do it.
curl -o pi-hole.json

Then go into rockstor web-interface and in the rockons menu click "update"
Then the new rockon should appear.

You can also do all this with other methods like SCP/WinSCP. You pick :slight_smile:

Remember to: When/If the rockon get’s added to the official registry you should remove this file so the official one will be used.

Thanks for this Rockon… I’ll test it as soon as I can as I’m interested in it.
In the meantime, I commented on a few copy-paste omissions in the json file. :wink:
I’m also a little puzzled by the container’s wording on the IPv6 option’s explanation so I’m not sure the corresponding choice for the default is the most appropriate.

Thanks again for your files!

The defaults will not work anyway… as i said sort if a quick and dirty WIP test :slight_smile:
Thanks for commenting on it i will make the adjustments to it. The IPv6 seems to best left turned off in most scenarios from what i can tell it mostly have to do if your network is IPv6 but most users and companies are still on IPv4.

Well, I got it installed, and it seems to be working.

There are bugs though. I for instance cant acces the web interface:

And some of the settings while setting it up were a little bit confusing.

But I did add the Rockstor server as my primary DNS, and I’m able to visit pages, so the DNS part seems to work.
It also seems to be filtering ads, and pages load very quick.

But it would be nice to have access to the Web interface :slight_smile:

Try this:

Gives the same error.

Could it be because I used port 83 instead of 80?

Could be. I used port 80 and it’s working for me.
Don’t really like the dependency of this port :slight_smile:


I’m uninstalling and will try again with port 80.

Sadly doesnt seem to work:

I cant get the thing to whitelist me :slight_smile:

Strange. As you can see from my screenshot it’s working just fine.
Did you specify the same IP adress for the server during the config part.
Can you perhaps paste the config summary page of the rockon here as screenshot (just leave out the password)

Here you go.

Strange that it wont work, everything seems to be working, its definately blocking ads as it should.

Ah i think i might have spotted a problem :slight_smile:
The IPv6 should be “true” or “false”
I use: false

Can you test to change that and see if it works better?

OK, tried changing that setting:

Sadly does not seem to work:

What I have to do is go to http://ROCKSTOR_IP/#home and that bypasses pi-hole.

Though I haven’t tried this docker yet, still running installed directly on system. I’ll try it soon!