Got a few Services Running on Rockstor (Dropbox, Pi-hole, Plexrequests, etc)

Here you go.

Strange that it wont work, everything seems to be working, its definately blocking ads as it should.

Ah i think i might have spotted a problem :slight_smile:
The IPv6 should be “true” or “false”
I use: false

Can you test to change that and see if it works better?

OK, tried changing that setting:

Sadly does not seem to work:

What I have to do is go to http://ROCKSTOR_IP/#home and that bypasses pi-hole.

Though I haven’t tried this docker yet, still running installed directly on system. I’ll try it soon!

Didn’t work here either, sadly. I get the exact same message.

Luckily everything else seems to work.

Oh, I can access the /admin page… :slight_smile:

Its only the /web that seems blocked.

1 Like

Rockstor uses https (port 443)
Cant you get in if you type that?

Oh forgot about https:/ my bookmark for rockstor has it https://192.168.1.121/#home

Interesting how the link to access this Rock-on’s webUI points to “/web”… Does anyone know where this could originate from? I tried to look into the container’s github repo but I couldn’t find a helpful corresponding line of code.

Ok, tried it out and it works well. I would suggest changing the webui link to ROCKSTOR_IP:PORT/admin because as stated above the /web is blocked by default. Can this be achieved by changing the slug variable? I am not familiar with the intricacies of the rockon json format :confused:

@Flox and @coleberhorst

Yes the “/web” bit of the UI URL comes from the Rock-on’s json slug entry. Look to the zoneminder json for another example of where this is used:


and it’s associated web interface url visible in the following section of the docs:
http://rockstor.com/docs/docker-based-rock-ons/zoneminder.html#zoneminder-ui
in the ZoneMinder Rock-on write up.

In that example for a host named “jstor.lan” and user interface port 8086:

jstor.lan:8086/zm/

Hope that helps.

Thanks a lot @phillxnet!
I (somehow) missed this section in the json file.

I still have an odd behavior regarding this link, however, Even though the link is correct (http://serverIP:port/admin, it fails to load the first time, and the browser automatically tries to open serverIP/admin. Upon manually typing serverIP:port/admin, however, I can access the webUI without any problem.
I get this when using both Firefox and Chrome.

It’s just a minor issue, but I was curious as to why this happens…

Thanks again!

Thanks!
I changed the .json file

@Fredrik I’ve also installed pi-hole, seems to work (at least I get the webUI running)
Is there any reason why your json-file is built on a rather old version of pi-hole?

WebUI shows the following message…version 3.X is available…

thanks

Hello Roland,
The json-file does not contain the docker image.
It will download the latest docker image available.

Docker image is coming from this: https://hub.docker.com/r/diginc/pi-hole/
Tag: alpine / latest
As far as i know this is the most used docker source for pi-hole.

OK, the WebUi points to…for comparing the versions…there it says 3.0.1 is the lastest

I wondered the same thing as you, and when looking at the container’s github, v2.13.2 is clearly specified.

It seems the upgrade to 3.0 is coming very soon, though:

The docker image was updated a while back so anyone who installs now get a 3.x version

@Fredrik

I have been using pi-hole ever since I first installed it.

But mine still reads:

I have tried stopping / starting the rockon. Uninstalling, downloading the json file again, and then reinstalling, but end up with the same older version.

What do I do to update?

I haven’t tried myself, but the container’s documentation reads:

If you try to use pihole’s built in updater it is not guaranteed to work; it almost assuredly won’t work for alpine but debian may. The preferred ‘docker way’ to upgrade is:

Download the latest version of the image: docker pull diginc/pi-hole
Throw away your container: docker rm -f pihole
Warning When removing your pihole container you may be stuck without DNS until step 3 - docker pull before you docker rm -f to avoid DNS inturruption OR always have a fallback DNS server configured in DHCP to avoid this problem all together.
If you care about your data (logs/customizations), make sure you have it volume mapped or it will be deleted in this step

I would try stopping the rocking, then docker rm -f pihole after making sure you have a second DNS setup, before finally turning the rock-on back on. As far as I understand, it should pull the newer image then.

Again, I haven’t tried it myself so I’m mostly supposing.

Hope it helps.

1 Like