Grub rescue installing Rockstor on Dell Dimension E521

Trying to install Rockstor on an older machine. This machine does not have ACPI but I have put several flavors of linux on it in the past.

The Rockstor installation seems to go flawlessly. Upon reboot I get:

error: no such device: xxx-xxx…etc.
error: unknown filesystem.
entering rescue mode…
grub rescue>

I tried adding acpi=off to the startup with no difference in the install.

I am a COMPLETE noob at linux but. I have tried this.
While in grub rescue>ls does show the drive list and
ls (hd1,msdos1)
does show it to be an ext2 file system.
both grub and grub2 directories are there.

set prefix=(hd1,msdos1)/boot/grub and several variations of this
insmod normal
gives a normal.mod not found

set prefix=(hd1,msdos1)/grub2
doesn’t complain

insmod normal
gives error: symbol ‘grub_strchrnul’ not found.

So tell me, is installing Rockstor supposed to be this difficult? I’m lost now.

Yup, they intentionally make it that way to scare off plebs. I promise.

You’re running this on 12 year old hardware, which is a bit of a stretch to expect an out-of-the-box experience on, but I digress.

This indicates that some grub components are missing or not loaded, likely a bad install, have you tried running the install again?

Otherwise, perhaps try a livecd with BTRFS support, mount and chroot to the Rockstor root then do a grub2 install?

I’ve also seen this on systems without any EFI framework (Not sure if E521 has EFI), it seems grub has trouble fitting in the memory available for booting.

I’m pretty sure it’s not an EFI. After hours of multiple reinstalls the only thing I found that worked was to remove one of the hard drives. I had a 70g that I was going to install the OS on and a 2tb for the backup. I removed the 2tb, reinstalled, reconnected the 2tb and it sorta works. I’m trying to get a Windows machine to backup to the samba share but even that’s giving me fits. The backup will start and then cancel. Came in this morning after trying to let it backup all night, now the windows machine can’t even see the share even though I can log into the Rockstor interface. And then, dumbass me turned the eth0 off in the Rockstor interface thinking I’d just turn it back on to reset it. That’s what happens when I don’t have enough coffee. So now, I’m off to wipe and reinstall Rockstor yet again because now it’s coming up with some internal error.

Remind me again why I thot a NAS would be a better idea than an external USB hard drive.