GUI not loading

Installed Rockstor on old laptop with no issues. Rebooted, loads fine. Ran Network Watcher to find IP. But when I attempt to load that IP, get “This site can’t be reached, 192.168.1.XX took too long to respond.”
I logged into root. Ran nmcli. Get lo:unmanaged and wlp2s0:unmanaged (for wireless). For wlp2s0, I see “plugin missing”
Ran nmcli device show, See ip4 address as 127.0.0.1/8 for lo/loopback so try that. Same access error.
Just for giggles, tried the command: services restart rockstor. No change.

Don’t know how to do the “Bridged Adapter in virtualbox settings” so plugged in wired connection. Rebooted Rockstor. Tried access again, no luck. Ran nmcli again. “p0p1: disconnected” on the wired.

Frustrated! I’m sure there is something simple here that I’m missing. Please help.

EDIT1: Some progress (I suppose).

Ran nmcli command to connect to wired connection. Now, p8p1 is connected. ip address shows, Network Watcher shows rockstor.#local.net. But when I try to access gui at either address, I still show “This site can’t be reached. Took too long to respond.”

EDIT2: More progress. Persistence pays off.

Used wired connection since it was running, kept trying different versions of IP/address. Turned off my McAfee (firewall and virus). Nothing. Kept trying and then received a weird #shell error. BUT, it appeared to be an error message within the GUI. After some random clicking, I ended up in the main GUI. Whew.

Only problem now is, I have no idea how to replicate what just happened. Trying to complete as much config as possible before I have to reboot.

Hi @RokStuk, and welcome to the community!

I’m sorry it has been under troubled circumstances, but I’m glad you got it sorted out in the end!

I’m not sure what happened but I can try to bring my two cents in case it helps somebody else or in the future. You may very well have already followed these little pieces of advice, but just in case:

First, it seems you were installing Rockstor in a VM, is that correct? With regards to the network, switching from NAT to Bridged should be all you need, as I believe the currently used connection is automatically selected as the adapter for it.

Upon first reboot after install, give the machine several good minutes alone as a lot is going on in the background to initiate Rockstor. This depends on your hardware, of course, but this is why sometimes the “welcome” message reporting the IP to access the webUI is not displayed at first. It will be displayed once all the first initiation steps are complete. If nothing appears by itself, a simple carriage return from time to time should do the trick to refresh and force the display of the message.

I’ll admit I’m confused by this one, as I’ve always seen a network connection through Virtualbox default settings to be seen as “ethernet” (with a name similar to “enp0s1”, for instance). I am thus puzzled as to why yours is detected as “wlp2s0”, which I believe is wifi-based (which also would explain the “plugin missing” note).

I’m sorry I’m not answering a lot of your questions (if any), but I do hope at least you’re now all set.
Please note that as the install ISO is rather old (new version coming, though), so I would recommend you to update your system after activating an update channel. If you do so, please give it quite a bit of time as well as there will be a lot of packages to update and you do not want to turn off your system while it’s running.

Sorry again for the rather difficult time you had, but make sure to let us know if you encounter any other issue or are not all set yet.

Cheers!

1 Like

Thanks, Flox. A few trials, yes, but worth it in the end. I couldn’t be happier with the outcome. I’ve experimented with FreeNAS and find RockStor to be far superior. What you say about waiting a beat or two to let RockStor do its thing is advice I wish I had before. Once the churning was done things started working as expected. I was just too impatient, I suppose.

Anyway, I may be a relative noob but I am a huge fan now. The interface is so straight-forward and easy. Once I finally got there I had multiple shares running in no time. Looking forward to working with it more.

Regards,
Rok-UN-Stuk

2 Likes