Have to rebuild raid 5 pool after reboot

I have to rebuild my pool every time I reboot my system. I it down properly and down just pull the plug. I had an issue before where the VM drive I had Rockstor installed to didnt have a UUID. I did that and it worked, but now Im running into this issue. Here is a screen shot of the errors Im getting when I boot. http://i.imgur.com/XgAQ1sh.png I have Rockstor installed on ESXi 5.5 and have a LSI RAID 9211-8i set to pass through going to Rockstor. I have 3 3TB HGST in a RAID 5.

Can you expand on what you mean by rebuilding the Pool? What command do you run and steps do you take?

Well I was running into the issue when it would boot it would say it was either missing sbb, sdc or sdd. I narrowed that down to an issue with the fstab, at least I think I fixed it. I ran a scrub and a balance and I could see all my data in samba. I rebooted and it worked so I thought I got the issues fixed. Well I powered off the VM that has Rockstor on it, shutdown the bare metal machine to install a UPS. Fired it back up and now when I try to access the pool in samba its only showing 10GB of the 3TB is supposed to be and the folder is empty, which is what was happening before. When I try and run a balance it says

Error running a command. cmd = ['/bin/mount', u'/dev/sdd', u'/mnt2/TV', '-o', u',compress=no']. rc = 32. stdout = ['']. stderr = ['mount: special device /dev/sdd does not exist', '']

Im not sure why I keep having these mounting issues. The strange thing that is happening is the folder that is shared with samba is still showing up in my network, but the folder is empty, but when I check the properties it is the same disk size as the pool that has Rockstor installed. They both are reporting back 10.3GB.