Hello im having the " sp5100_tco problem " at boot

hi ,i recently started to use your NaS SO as it seems the most easy to use ,yet powerfull options to other more “advanced”. The only issue im having is this message at boot “sp5100_tco is registered at address xxxxxxxx”.

googling is seems to be a bug about ATI chipset , the computer ive used for NaS is an HP microserver G7 N54L 12GB ECC certified ,2x2TB WD green ,1x300GB WD velociraptor ,and a 500gb laptop hitachi drive.

the system is instaled in a little ssd about 32gb sandisk,ive installed it from DVD ,and everything went fine ,but sometimes the system get stuck in the boot saying that message.

thank you in advance and sorry if this question is solved elsewhere ,im unable to find it.

no one can help ? its a serious issue not like one that can be avoided…

The lack of response may just be down to this not really being specific to Rockstor, ie any newer kernel distro may suffer the same. You may have a greater volume of response if you can also observe the same response in a generic distro and ask on their forum. Rockstor is essentially a CentOS 7 with a much newer elrepo ml kernel installed plus a few other Rockstor related packages updated and of course the code that is in the Rockstor repositories / package. This sounds like a kernel issue due to it being driver related. We change nothing about the elrepo kernel so maybe that would be your next port of call.

Hope that helps, although it’s worth waiting a little longer here as there are a few forum members who also run Rockstor on various HP microservers but not sure I’ve seen mention of G7 specifically.

thank you for your kindly answer ,truth is ive never used CentOS so im not sure if i can pop the same bug with a normal distro. the only linux based OS i had problem with was ubuntu 14 desktop version 32-64 bit both(older versions worked pefect). other OS like steam,windows,freenas,and solaris worked without any problem.

anyways because im spanish maybe i did not explained myself correctly , let me try again.

the problem or bug is that even showing the message ,sometimes the system work ,boot and operate as intended.
some other times it just stop in that message and get stuck forever.

maybe the message have nothing to do with the boot stuck problem?
im sorry if i didnt explained myself correctly ,for example linux 14 does not boot 100% sure ,but this system sometimes boot ,some other dont.

can anyone point me to the logfile where the boot “bug/error” could be tracked ? (as i told never used CentOS )

thank you in advance and sorry if im being a bother :stuck_out_tongue:

well after trying to point or find the problem , 1 of 25 power ups ,the system run as intended , this server never had problems with freenas,windows and many other SO, so im sorry but i will go back to a system that boot and WoL 100% of times without errors ,problems or failures.

also as a note most features pop a window with code error and the line where the error is ,so it seems like this SO is been just 1 month old.

the only regret is that i have payed 1 year of “worthless” updates cause this system does not even offer help at all.

its been a pleasure ,have a good day.

i have the same problem on my hp microserver and it´s really annoying…


After disconnecting my temporarily used USB Keyboard Rockstor boots like a charm :slight_smile:

Crazy world…


Yes that is a bit crazy. Not directly Rockstor related but funnily enough the other day I had an Ubuntu laptop that would not suspend after I changed it’s usb keyboard. Solution was to use the same keyboard but not though the usb hub that was also attached. Strangely this hub had allowed suspend just find with a prior usb keyboard plugged into it. Oh well.

Thanks for reporting this by the way, never seen that before.