Hit the upgrade button and now sabnzbd is not in list - but still running!?


Like the title says: I hit the upgrade button, by mistake I might add, and I got an error message relating to Plex. I ignored it as i didnt want or need to upgrade anything. But later i noticed that my Sabnzbd rockon was missing from the list of installed rockons. I thought it was FUBARED and I had to reinstall it, but it wasnt in the “not installed” list either…?
When I accessed its url it was still working fine!?
Anyone know how I can get it back in my list of installed rockons?

Maybe its best to use the “delete” script mentioned here on the forum, and reinstall it?



Hi @baretomas, and welcome!

I’m sorry to read you’re having issues, but I’ll try to help.
First of all, I suppose that by “upgrade button” you mean the “update button” so I will assume this from now on. Please correct me if I’m wrong.

Let’s try first to fix the problem and I’ll then provide some information on what happened and the error you received. The fact that Sabnzbd is still working fine does mean, indeed, that the problem only lies with getting it back to the displayed list of rock-ons.

This will indeed work, but let’s try to see if we can try something much simpler first. You most likely already tried what I’m going to list, but it’s worth asking and/or trying just in case as it would save you the rock-on reinstall.

  1. Refresh the page (Ctrl + Shift + R in Chrome). Indeed, Rockstor updates the status of all rock-ons when loading this page so this may refresh whatever status is in limbo.
  2. Click the Update button. Similar to above, this will trigger Rockstor to fetch the list of rock-ons available from the server and update the local information accordingly. See below if you see an error as you did in your original post.

If neither one of these work, then yes, I would go ahead and try running the delete script. As a reminder, you can see in the post linked below for more details. In the case of Sabnzbd, you would need to run the following command:

/opt/rockstor/bin/delete-rockon sabnzb

As you probably already saw, this script will wipe all reference to this rock-on in Rockstor’s database, so pressing the Update button afterwards should reset its status to “available” and you will be able to install it again. Using the same shares as before will allow you to get back in the same state/config as you were before.

Now, let’s talk about the error you saw, what happened, and why.
I assume you saw an error similar to below:

Error while processing remote metastore at http://rockstor.com/rockons/root.json. Lower level exception: HTTPConnectionPool(host=‘rockstor.com’, port=80): Max retries exceeded with url: /rockons/root.json (Caused by <class ‘socket.error’>: [Errno 11] Resource temporarily unavailable)

You message was most likely slightly different and mentioned Plex, but is essentially caused by the same thing: a simple web timeout. This means that trying again usually works. As it reads the configuration of each rock-on one after the other, it will report an error for whichever rock-on was being processed when the timeout occurred (Plex in your case). Although this isn’t a big deal per se as trying again usually works, it seems to have conflicted with checking for and updating the status of your installed sabnzbd rock-on. I’m unsure how that happened exactly, unfortunately, but I have a couple of ideas on a few improvements we might be able to add in order to ensure that what Rockstor displays is in sync with what is running on the machine, for instance. It may be a little while until I can try to seriously look at that, however, but I’m hopeful this will get improved and be more robust in the future.

Overall, give a try to the reload (1) and update button (2) options first, and if no change, then go ahead with the delete-rockon script. That should fix it, but let us know how it goes!

Hope this helps,

1 Like

oh wow! Thanks for a prompt and great reply!

You were assuming correctly with the Update button, and not Upgrade ofc.

I did try to ctrl-shift-f5 to no help.

I now tried to hit update again, and it was not actually Plex that was the matter, it was NZBHydra, and I think now I know what has happened, but I am really not sure if I did anything wrong to make it happen.

it seems nzbhydra is the culprit, and is complaining that the already installed rockons volume definitions (shares?) cant be removed, because the already connected to a rockon…? I dont think I reinstalled hydra recently. Most sure it is a fresh install.

Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 106, in post
self._create_update_meta(r, rockons[r])
File “/opt/rockstor/eggs/Django-1.8.16-py2.7.egg/django/utils/decorators.py”, line 145, in inner
return func(*args, **kwargs)
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 267, in _create_update_meta
handle_exception(Exception(e_msg), self.request)
File “/opt/rockstor/src/rockstor/storageadmin/util.py”, line 47, in handle_exception
RockStorAPIException: [‘Cannot add/remove volume definitions of the container(nzbhydra) as it belongs to an installed Rock-on(NZBHydra). Uninstall it first and try again.’, ‘Traceback (most recent call last):\n File “/opt/rockstor/eggs/gunicorn-0.16.1-py2.7.egg/gunicorn/workers/sync.py”, line 34, in run\n client, addr = self.socket.accept()\n File “/usr/lib64/python2.7/socket.py”, line 202, in accept\n sock, addr = self._sock.accept()\nerror: [Errno 11] Resource temporarily unavailable\n’]

Thanks for reporting this error, was that the same error (but with Plex) that you encountered in your original post?
That error is different than what I described in my previous post, however, but it is nonetheless possible to resolve it with the same solution: delete-rockon script. Indeed, as the error message states, while refreshing and updating the volumes definition for this rock-on (NZBHydra) Rockstor encountered a rather abnormal case in which one (or more) of the volumes defined in the rock-on definition does not exist in Rockstor’s database anymore. As this was detected for a rock-on currently installed (as per Rockstor’s database), Rockstor stops there in order not to break a currently installed rock-on.

So to fix this, you can uninstall NZBHydra, and then click the update button. Alternatively, you can force its uninstall using the delete-rockon script (/opt/rockstor/bin/delete-rockon NZBHydra) and then click Update. Everything should be then reset to its default values.

Sorry I’m not able to provide more details as to what happened… this seems to be a rather “particular” case and I would need to find a good way to reproduce that in order to fully understand what happens and whether or not we can find a better way to deal with it.

Hope this helps,

I think it wasnt Plex that gave me error the first time now. I probably remembered it wrong. Sorry about the confusion.

I deleted the NZBHydra rockon and clicked update. Now the update doesnt give any errors, but SABNzbd is still not in any list.

I guess I should just delete it, and see if it pops up.

Thanks for all help! Much appreciated. Love the product, 2 weeks in of using it.

Yes, I would do that using the delete-rockon script. That should help move things forward.

Yup. Up and working now.
Thanks again!

Great! Thanks for letting us know.