[host: Lubuntu 16.04LTS][guest: Rockstor 3.8-14] :error during username/hostname creation

Hi all,

In order to discover and test this NAS appliance, I build a VM using VirtualBox 5.0.22 r108108 and when I do the first step in https://myIPaddress, I got this error message:Houston, we’ve had a problem.

Unknown internal error doing a POST to /setup_user

I have nothing in the traceback and nothing in /var/log/messages.

I also tried different combination of username and hostname without success.

I didn’t find any topic with this issue and that’s why I created this topic.

So could I have some help to check why I’m getting this error or at least tell me where I can find the logs for this error message.


Hi @BENKHESA1 samir and welcome to Rockstor Community.

Can you provide more infos about conf and steps for this VM??


Hi Mirko,

these are the information:
Processor : 8x Intel® Core™ i7-2670QM CPU @ 2.20GHz
Memory : 6119MB (577MB used)
Operating System : Ubuntu 16.04 LTS
User Name : samir (samir)
Date/Time : Sat 25 Jun 2016 07:19:42 PM EDT
Resolution : 1366x768 pixels
OpenGL Renderer : Mesa DRI Intel® Sandybridge Mobile x86/MMX/SSE2
X11 Vendor : The X.Org Foundation
Audio Adapter : HDA-Intel - HDA Intel PCH
-Input Devices-
Lid Switch
Power Button
Sleep Button
Power Button
AT Translated Set 2 keyboard
Video Bus
AlpsPS/2 ALPS GlidePoint
Dell WMI hotkeys
HDA Intel PCH Mic
HDA Intel PCH Headphone
HDA Intel PCH HDMI/DP,pcm : 3=
No printers found
-SCSI Disks-
Generic- Multi-Card

Type: linux
version: 2.6/3.x/4.x 64bits
CPU: 1
Storage: 4x 100GB SATA HD
Network: 1 Ethernet in bridge mode
USB: USB 2.0

1- Use the default values
2- HD: use HD1 for the installation
3- reboot after installation complete
4- Access https://MyIPaddress
5- Accept the license agreement and create hostname and username

Hi Samir, i supposed you’ve already tried to access it again (without success), so we need to grab some logs:
Log via ssh to rockstor and get rockstor.log under /opt/rockstor/var/log : looking into Rockstor logs probably we can solve it


1 Like

@BENKHESA1 and @Flyer Just a quick thought but on first boot and login maybe there is a greater memory pressure.

From the specs given the Rockstor instance has only 1.2 GB of RAM but the Quick start docs under Minimum system requirements state 2GB as a minimum for RAM.

This might simply be an out of memory thing and a quick re-install using 2GB or more RAM for the Rockstor instance might be all that is needed. Got to be worth a try I’d say.

1 Like