Install Error HP MicroServer Gen8

I am trying to install Rockstor on my HP Micro Server Gen8 and getting an error, and I’m not sure what to do with the error. NOTE: I previously had TrueNAS SCALE installed on the server.

I wrote the .iso file to USB using Fedora Media Writer (which was mentioned on one of your pages), I also note that you recommend Rawrite32 for windows, but I’m not sure what i’m writing with this tool?

During the install I get as far as choosing which disk to install on:
image

I answer Yes to Destory everything on the disk, then it runs through the Loading Rockstor-Leap15.3-generic.raw, then I end up in the Emergency Mode.

I’m not sure how to get the report onto a USB drive, or what to do next.

Any help/suggestions greatly appreciated. My Linux knowledge is very basic.

image

@vbtrek Welcome to the Rockstor community.
Re:

So is that directly after the progress bar and before a reboot? Or are you getting dropped to the emergency mode only after rebooting when the install has finished. I.e. after setting the root password etc:

https://rockstor.com/docs/installation/installer-howto.html#installer-howto

Also you screen grab looks a little strange with some character distortion, i.e. those little squares in the first two lines!! There is a small chance this is down to a ram issue. That would certainly upset things.

There are other Gen8 users on the forum I believe so maybe they can chip in with other suggestions. Not sure if they are yet running the v4 “Built on openSUSE” variant yet thought.

Also you should make sure your download file is good via the checksum instructions on the downloads page. Just in case. And if you install USB disk is duff that too could break stuff.

@doenietzomoeilijk Are you still around and if so have you now moved to our v4 offering?

I assume that the proposed system drive (the 55.9G drive) is relatively healthy.

So in short, double check your download via downloads page instructinos.
Try a different installer medium to copy the iso over to. Just in case it’s poorly.
Try and check your machines memory.

Hope that helps.

1 Like

Thanks for getting back to me.

Yes it’s directly after the progress bar and before any reboot occurs.

I’ll check the download and test the memory and try another usb stick, I’ll get back after I’ve done all this.

I’m installing on an ssd drive I have in the server.

The odd characters could be down to the iLO remote console, not sure.

3 Likes

I’m still around, but in the meantime I’ve moved to a bare-bones OpenSUSE install that I manage through Ansible, so not on Rockstor anymore.

With the character distortion going on in the image, I’d agree with rooting out hardware issues first.

@vbtrek How do you boot from your SSD drive? Bootloader on USB media, set up the SSD as a single drive RAID in the HP storage assistant thingy, put the SSD in one of the “main” drive bays, other?

3 Likes

Hi @doenietzomoeilijk,

The SSD is attached the the CD connectors inside the server and each of the 5 drives are setup as single drive RAID in the HP Storage Assistant, then you can set which drive is the boot drive also in the HP Storage Assistant. The boot order is set for USB first then hard disk in the bios.

I wrote the iso installer to USB pen drive using Fedora Media Writer, boot with this USB inserted and run the Rockstor installer to install on the SSD drive.

I don’t think there is any hardware issues, I was running TrueNAS SCALE just yesterday on this box without any hardware issues reported, and prior to that I ran XPenology for a good few years without issue. But I can happily do some hardware checks to be on the safe side.

I have moved the SSD into a USB caddy and attached it to the internal USB connector, installed from the USB pen drive to the SSD in the USB caddy and hey presto the install worked fine and it’s now up and running.

3 Likes

Good to hear it worked out!

Just for completeness’ sake (not something you’d likely want to change now that everything is running, but maybe for future reference): you don’t need to add the “data” drives in their individual raids. Just need the SSD (otherwise, as you noticed, you can’t set it as boot), but the rest of the drives that are not set up in the RAID controller get passed through to the OS, and you can use them just fine there. Added benefit: they’re hotswappable.

With the SSD through USB you might miss out on a bit of performance, but if that was your biggest concern, you wouldn’t be running an older Microserver in the first place - the ODD SATA slot isn’t a full speed one, either. Good to know that option works, too, every now and then the Microserver forgets about that lone SSD and no longer boots from it, requiring a trip through the storage assistant to set up the same RAID on the same drive again to get it to boot - it’s not difficult, but it eats time. I’ve taken to using kexec rather than actual reboots to cut down on the reboot time, those enterprise machines like their long POST checks and screens :wink:

2 Likes

Thanks for the info on the data disks, I’ve not setup any pools yet in Rockstor so I might just remove the data disks from raids in the HP Storage Assistant, I didn’t realize you could do that.

I realize the performance of the SSD isn’t going to be quite as good running it through SSD, but I only really run Home Assistant home automation and a bit of file sharing from this box so it should hopefully be ok.

1 Like