Install Error NoSuchPackage

I’m totally new to Rockstor, not great with Linux and have deep experience with storage and network solutions. With that prefer, I’m running into an install error that I hope someone can help with. Yesterday I downloaded the latest Rockstor build, burned it onto a DVD and started the installation process.

The DVD booted great, I selected my time zone, OS drives and clicked next. The install process starts and after a few moments it crashes. When I switch over to the command line I get this error NoSuchPackage(pkgid).

The complete error is shown on the attached picture.

I assume I’m just doing something wrong, but I can’t seemed to figure out what the issue is. Can anyone with more wisdom then me please point me in the correct direction?



Hi @akotter, welcome to Rockstor community!

Is this problem with the latest ISO(3.8-9.02)? My first suggestion is to download it again and repeat the process. If you can install from USB, it will save you time and DVDs. In case you haven’t seen it already, here’s the quickstart guide.

Correct, this is with Rockstor-3.8-9.02. I tried two different downloads with both a USB and DVD. With the USB I had several issues creating the boot drive (as noted on other post). I both cases I got this same error. Is there a place I can download an earlier ISO?



Has anyone else tried to install with the latest ISO? I’m excited about the potential of a good brtfs NAS, but right now I can’t do a basic install. It’s probably something I’m doing wrong, but I’d love to know if anyone can make the latest ISO work.

The error screenshot you posted seems to indicate that something may be wrong with the ISO, so I’ve done the following:

  1. downloaded 3.8-9.02 ISO from sourceforge
  2. verified that it has the right md5sum(ba18cce56119c155a794b9704b2ff266)
  3. transferred it over to a USB stick using dd if=Rockstor-3.8-9.02.iso of=/dev/sdb (/dev/sdb is the USB stick in my case)
  4. Installed on a physical machine using the USB stick successfully.
  5. I was also able to install on a VM without issue.

I recommend you make sure the md5sum of the ISO matches the above. Secondly, how are you creating the USB install disk? If you are using dd method, I don’t see how your experience will be any different from mine.

If you are on Windows and want to create a working USB Stick, use Rufus. And as @suman said: use dd-method, not the iso-method. :smile:

Thank you for the feedback and suggestions. I verify the md5sum and created a working USB drive with Rufus using the dd-method (thanks @Yoshi). Using the GUI interface everything looked great right up to the point of installing the packages and I got the identical NoSuchPackage error.

I don’t think it’s my hardware, because we don’t get to that point in the install process. When I click the debug and exit out of the GUI I get the same message as above. Any other thoughts or suggestions?

Thanks !


I think it most likely is the USB creation process. I am not a windows user, but the quickstart guide states that Rufus is problematic. May be you want to try “dd for windows” or Rawrite32. See quickstart guide.

You could also buy the USB install disk from our shop, which would be greatly appreciated!

@akotter if you are still having issues, I recommend you check the quickstart guide again. @phillxnet has updated it with instructions using Rufus on Windows. Hope it will get you unstuck.

Thanks for the great suggestions, I appreciate the help. I’ve gotten a little obsessive about making this work from a Windows USB creation tool. So far I have tried Rawrite32, Rufus, Pendrive Universal USB installer and LiveUSB creator for Fedora. I’ve tried the settings in the quickstart guide and every other combination I can think of. I also did many of the same processes with blank DVDs.

So far all have crashed in the exact same spot opening the packages for install. I did verify the ISO mdhash and tried two different ISO downloads. I agree the issue is probably with my installer, I was just hoping to find the issue and have a solution for future users. At this point I’m not sure what else to try so I’m going to order the install media or use a Linux box to create the USB drive.

Can you try installing Rockstor on a virtual machine on desktop you downloaded the ISO on? I’ve installed in a virtual guest using the plain ISO and there weren’t any problems. If you can install a VM with the ISO, then it’s definitely the USB creation.
I was using a USB stick at work the other day that refused to write beyond a certain point. Wiped, formatted, tried again - stuck at the same point. USB key was borked. Can you try using a different key?