Install failure

My Rockstor server died of old age (i.e., the plastic tab holding the CPU fan in place broke and it was downhill from there). So now I’m installing on a new MSI Pro-B650P motherboard and Ryzen 7 CPU.
I created the USB boot with Rockstor-Leap15.4-generic.x86_64-4.5.8-0.install.iso and Rufus using the Rufus instructions here..
[edit: same result after creating USB stick(s) with Balena Etcher)

The install gives (I’m typing this so forgive me any typos):

Loading kernel…
error: …/…/grub-core/kern/efi/sb.c:180:shim_lock protocol not found.
Loading initrd…
error: …/…/grub-core/loader/i386/efi/linux.c:207:you need to load the kernel first.

OK, the second error is obvious given the first error.

Same error using either install option.

Bad iso? Seems unlikely but…?

Thanks for any suggestions.

Installing now. Through trial & error, disabled Secure Boot in the BIOS. Disabling TPM was insufficient (and was re-enabled). Secure Boot seems to be a hidden setting in that I couldn’t find it in the menus but I did find it via the BIOS Search function. A bit wonky but seems to have fixed the problem.


Good to know. We should probably add that piece of information to the Rockstor documentation, if that’s a persistent issue. I found this in an article in PC World about it:

Modern versions of Ubuntu, Fedora, openSUSE, and Red Hat Enterprise Linux all “just work” without disabling or configuring Secure Boot. They use a small “shim” boot loader signed by Microsoft, which in turn confirms the main boot loader was signed by the Linux distribution before loading it. Some other smaller Linux distributions also use shim.

and here it is also discussed.

@phillxnet is that something that the Rockstor installers might be missing (or it doesn’t come with the JeOS basic image and would have to be added manually?


Thank you, @Hooverdan . Good finds there, especially the openSUSE:UEFI article.

Kudos to your code: after I installed Rockstor I restored a config backup from last year and it worked like a charm: my data drive was there (no need to import the btrfs volume), users, rockons, and SAMBA shares all there as if nothing had ever happened.