Install problems with basic graphical mode [Solved]

I have installed Rockstor 3.8.0. As this is the lastest iso available. I have to use the minimal graphical mode to install. works fine. After the server boots up and i visit the Web-ui i find a problem.

'root filesystem is not BTRFS. During Rockstor installation, you
must select BTRFS instead of LVM and other options for root filesystem.
Please re-install Rockstor properly.'
If you need more help on this issue, email us at with the following information:
The error message: "‘root filesystem is not BTRFS. During
Rockstor installation, you must select BTRFS instead of LVM and other
options for root filesystem. Please re-install Rockstor properly.’"A step by step description of the actions leading up to the error.Download the tarred and zipped server logs by clicking here, and attach it to the email.

The problem is. I used automatic partitioning BOTH times I have installed this. I looked at the advanced partitioning but there are a ton of options I am unsure about…

Thanks for any help,

@Dustin_Van, try to zerofill your disk first, so it is really clean, you might have leftovers from previous installs. That should do the trick then you just let the installer do the work.

I don’t know your experience level but the best way would be to get the gParted live cd, boot from it, then make sure you select the correct disk /sda for example, then delete all partitions.

Happy Rocking!

@Dustin_Van welcome to Rockstor community! It’s a bummer the GUI installer didn’t work for you. When you select the auto partitioning, it may be defaulting to LVM part scheme. See if you can change that to btrfs. Good luck!

There was a ton of settings in there. What should the setup for the manual partition setup look like?

I started with a clean disk the first time.

In the first comment you mentioned that you used automatic patitioning. See if you can pick auto partitioning but with BTRFS as the filesystem. In the GUI installer, you can pick auto partitioning scheme for any of the filesystem options, LVM being the default if the provided ks.cfg file doesn’t kick in.

@suman Just had a look into this and there is no ks boot line entry or ip=dhcp when using “Troubleshooting - Install Rockstor in basic graphics mode.” so I’ve created a github issue for it.

@Dustin_Van It appears the ks.cfg that @suman mentioned is in deed not being picked up during the basic graphics mode install. Until this is sorted the easiest work around is the following:-

Select "Troubleshooting"
Highlight "Install Rockstor in basic graphics mode" but don't press enter yet
Press the TAB key
This should bring up some text at the bottom of the screen
To this text add the following.
ip=dhcp ks=hd:LABEL=Rockstor\x203\x20x86_64:/ks.cfg
You can now press ENTER

The screen should look like the following just prior to pressing the ENTER key:-

Note that the trailing underscore character at the end is actually the cursor.

The effect of this it to inform the installer of various package selections and partitioning requirements, hence your difficulties.

You should now find that things are simpler, although because you already have a system installed on the system disk (the leftovers that @TheRavenKing referenced) you will have to follow though with a - reclaim space - delete all - reclaim space - selection flow. You will be prompted with dialogs that offer these options once you press done on the “Installation Destination” screen.

Hope that helps.


Thanks that worked like a CHARM! One more question. I have two 2TB drives that are currently formated to EXT3 and Mirrored from an old os at raid 1. How would I go about moving filesystems? Without loosing all my files.

Very nice. +1 for @phillxnet

What is the nature of the current raid 1 setup? hardware/software?

I have not done this personally, but here’s the tutorial. Once you’ve manually converted to btrfs, the ui should let you import it as a pool. I am not clear about your setup, perhaps you’d some how turn off the raid first, add one of the devices in raid1 as a “single” pool, verify all your data is there, and then wipe the second one, then add it to the pool via resize feature. Again, I have not done this before. Backups are strongly recommended.

@Dustin_Van The linked issue that you helped to discover has now been closed by @suman 's recent work on the next iso release, I’m afraid it’s not out just yet but my tests on a pre-release from the perspective of the problem you ran into; all looks dandy. Just to let you know and thanks for reporting and helping out.

@Dustin_Van Just to round out this thread properly @suman has now released the official 3.8-7.iso with the fix for the issue raised as a consequence of this thread incorporated so if you need to re-install in basic graphics mode again it should now not be required to add the previously missing options. Cheers.

Unfortunately there is as yet no iso only issue fix lists so no fame and glory on this one. :smile:

1 Like