Issue with Samba on OpenSuse Leap 15.1

Hello,
I just enabled samba with a basic configuration.
It seems that if you want to login from mac/windows the access is always denied.

Removing those lines from rockstor smb.conf configuration fix the issue:
root preexec = “/opt/rockstor/bin/mnt-share sharename”
root preexec close = yes

There are no errors in the logs except the permission denied to login.

Can anyone else reproduce this?

Hi @shocker,

That furiously looks similar to a recently identified particularity for samba in our “Built on openSUSE” with regards to AppArmor. See the post below:

…and the detailed instructions written by @phillxnet in the dev notes, in particular the section entitled “Stop and Disable AppArmor”:

Try these first and make sure AppArmor is disabled after a reboot; it should at least help with your issues.

1 Like

Thanks @Flox
Wasn’t aware about that post :slight_smile: I have disabled it but unfortunately I cannot reboot the system right now. Only stopping the apparmour is not fixing the issue. Also disabled the ipv6 via sysctl -w for the moment.

I’ll come back with a feedback after my btrfs delete comand will end. I think it will take a week or so :slight_smile:

P.S. I think a warning in rockstor web gui that the apparmour is not disabled will help users a lot :slight_smile:

Yeah that should help.

As explained by @phillxnet, AppArmor will be disabled by default in the new installer so that shouldn’t be a problem for now. I believe the goal would be to make Rockstor compatible with AppArmor in the future, though, so that can of indicator would definitely be a good idea.

1 Like