Jdownloader-2 rock-on is not working

Hi, sorry for the hope-not-so dumb question. I’m pretty new to rockstor, so please be patient with me.

I’ve just installed the system, created all the “storage” stuff, gave permissions to the users, updated the system and activated the rock-ons.

My first rock-on was Nextcloud (and it didn’t work, so I had to uninstall it… but this is another story), then I successfully installed Emby, then I tried with jdownloader that doesn’t seems to work.

I’ve configured the system to be separated from the files downloaded (two different volumes as recommended), I’ve left untouched the ports to reach it’s web-ui, I’ve double checked my UID and GID before insert it.

I deploy the rock-on and I see it active in the rock-ons installed.

Now the problem is that when I click on “jdownloader 2 UI” it sends me to the right address, on the right port, but there’s no connection.

Also in the rockstor log there’s nothing that refers to my problem.

Is there something I’m doing wrong? What can I try?

1 Like

@TheJoe welcome to the Rockstor community.
I ran a test on a VM and I was able to connect to the jdownloader 2 UI.
When you click on the UI button in the Rockons, does it try to take you to:
http://<Rockstor IP>:5801/ ?

Just trying to see what else could be the root cause for it not working as expected for you. The Emby Server is reachable and functional, though, correct?

you could also see whether using the command line
docker logs jdownloader2
provides some insights …


Hi @Hooverdan , thanks for your reply.

Yes, Emby was reachable and functional, but then I had the idea to install Nextcloud too and everything broke. The error message was very generic and the “detailed version” was empty. None of the other rock-ons were working and I think the problem is that I’m running my OS on a USB stick (I’m still making some test).

In the next days I’m planning to make a fresh install on an HHD and see if I’m getting the problems from there too.

Thanks for the support.



If you mess up the rockon share with some experiments, just turn it off, delete the content of the share, and restart rockon. Then it will create new config files, and you can start all over.