Jellyfin UI not functioning

Having trouble accessing the Jellyfin UI in order to add shares to the Jellyfin system.
Started with Movies which work fine on the Samsung TV (Just popped up in the source section) and also works fine on an Android tablet.
This is the screen when selecting the Jellyfin UI Tab on the Jellyfin Rockon
Jellyfin%20UI%20loading%20page%20error
Tried a host of possible remedies reset IP config etc
Get the same result in all devices.
Any ideas would be appreciated
Thanks

Hi @Mike-B,

I must apologize for being very brief here; I unfortunately cannot detail more.
We’re hitting a known issue here, one that will be worked on soon. Try replacing the 8097 bit in the URL on your screenshot to 8096.

If that works, then I would recommend reinstalling the jellyfin Rock-on and choosing the default ports 8096 and 8920 (from memory, but verify with the tooltips during the installation wizard).

Sorry again for the lack of information here, but I just wanted to get you going first… I’ll try to be more informative soon unless somebody else beats me to it.

2 Likes

@Mike-B I just wanted to confrm what @Flox has said: replace the values 8097 and 9021 with 8096 and 9020 respectively, and you should be good to go. No idea why the default values are set to those already populated in the Rockon setup, as they are not at all standard for Jellyfin.

2 Likes

Thanks @Flox and @GeoffA
I had tried changing the 8097 to 8096 but not the 8920
So access to further libraries are now possible, just a further problem as I can’t seem to enter the correct path, Tried many many different combinations to no avail.
Jellyfin%20Library%20path
Could you help with this?
Thanks

@Mike-B, not sure whether you have figured it out already, but in any case, this is how I set up JellyFin:

image
The PUID and PGID are the actual “owner” of the movie library (so it can write metadata, etc.)
The /media share is mapped to my main Disk Pool that, among other things, contains a video library.

Once the initial setup (user, etc.) on the WebUI is run through, added a library like this:

Clicked on the “Folders +” like you did, then navigated from there:

image

selected /media, which in turn shows all the folders from the main RockStor share:
image
selected Video and further iTunes Video:
image
which was then the final path.
image
completed the setup and logged into the WebUI, and voila, some movies showed up:

image

Hope, that helps.

2 Likes

Thanks @Hooverdan
Notice you have the same “code” for both PUID and PGID when mine seem to need 1000 and 100.
I don’t have a pool name to select when setting up the rockon only shares are listed in the drop down list for media storage.
If the Movies share is selected, there doesn’t appear to be any other shares available in any library, (hence my initial query), however movies are available when the Movie share is selected as storage but only movies in the Movie share.
I don’t know what to enter for the device /VAAPI entry, itappears to be optional so left it blank.
PS
When using a touchscreen (Android tablet), the little info “snippits” don’t function.

@GeoffA, I just wanted to bring some background on your following comment:

You are entirely correct that it shouldn’t be that way and ends causing problems as @Mike-B has encountered here. Anecdotally, this is an issue that came to light when @StephenBrown2 worked on adding the Jellyfin Rock-on (https://github.com/rockstor/rockon-registry/pull/227#issuecomment-680037260) and represents an unforeseen consequence of a problem first identified by @henfri (https://github.com/rockstor/rockstor-core/issues/1208). Here’s the bit of interest from the first Github reference:

Indeed, Rockstor automatically detect whether a port setting is already used by another rock-on and increment it by one until it finds an available one. That is a great feature that usually prevents the user from unknowningly set an unavailable port and finds one for you, but in this case it backfires. This is due to the fact that we use the host mapped port number to generate the “webUI link”, which means that we are in this case linking to an unused and incorrect port. For instance, the webUI port for Emby is 8096. This is also the case for Jellyfin. During Jellyfin install, Rockstor detects that Emby is already reserving port 8096 (even if not installed) and thus automatically suggests the next available port (8105 in my case). After install, this result in the webUI link pointing to 8105, which is wrong as this port is not actually used (Jellyfin UI is actually accessible at 8096 due to its host networking setting).

We have an opened issue on Github to fix this (https://github.com/rockstor/rockstor-core/issues/2209) and as you can see we have already thought quite a bit on how to address this. The v4 stable milestone has been taking pretty much all available time so I have not been able to work on code changes yet, but I’m hopeful it will not be too long anymore until the “code work” on this starts.

2 Likes

@Mike-B, the PUID and PGID in my case just happen to be the same (was one of the first users/groups I created a long time ago, I think I even forced the PGID to be the same but don’t really remember), so if yours are different, that’s probably still correct.

sorry, should have been a bit more clear. I used a share that I created that covers the entire main pool for my files (including the aforementioned video directory). So, I of course used the share name, since, as you pointed out correctly, the pool is never visible during the Rockon configuration. That’s why I am showing multiple directories to choose from when trying to add folders. I didn’t create a “movies” only share prior to the Rockon setup.

As for the /VAAPI entry, this is really only relevant, if your processor supports the transcoding natively. It’s the same approach that Plex takes (as far as I know) taking advantage of Intel’s QuickSync, so I used the /dev/dri to populate. But, like you said, it’s optional. And, if you’re interested in that, you probably have to read up further on jellyfin to see whether it is really the same or different.

2 Likes

@Hooverdan
Thanks for the explanation, looks like the best approach now would be to just set up with the Movies share as it works for all my devices and wait for the completion of work by @Flox.
I could reset the shares and put all the media “folders” into one share and go from there.
Think I might try that from the Win11 file explorer just too see what happens.
Won’t be for a while as it’s New Years Eve tomorrow with a full schedule.
Happy New Year to all
Mike

3 Likes