Jumbo packets possibility

i want to enable jumbo packets but im not very familiar with linux command lines… help?

Hi @Karney_Chen,
we have an open issue with this :wink:


oh thank you so much
by the way does anyone know how to change the state? my computer supports 1000 yet it is using 100
also what is the command line used to change the MTU?
sorry for asking so much im a noob

I think that’s a graphic typo. I show the same but if you run ifconfig on the cli it clearly shows 1000. You should be able to set jumbo frames using nmtui on the command line. It’s a text based network configuration. I’d give that a shot.

@magicalyak Do you fancy opening an issue on the 100/1000 issue to help make sure it doesn’t get forgotten?

1 Like

I set my LAG up with mtu 9000 but no matter how many times I click submit, the webui still shows as 1500.
cat /sys/class/net/LACP_01/mtu shows 1500. Is there any other way I can force 9000mtu?

I know this is old but it may be related to a RHEL issue where until NetworkManager-1.0.6-27.el7 you couldn’t set MTU on a bond interface. Note that you only need this on the bond ifcfg, it propagates to the members automatically.


grep MTU /etc/sysconfig/network-scripts/ifcfg-*

You can edit the following to add this (ensure value is between quotes)

Then create this file if it’s not there in /etc/NetworkManager/dispatcher.d/



        if [[ $2 == up ]]; then
                MTU=$(awk -F "=" '($1 ~ "^MTU") {print $NF}' /etc/sysconfig/network-scripts/ifcfg-$CONNECTION_ID)
                if [[ $MTU > 0 ]] && [[ $MTU != 1500 ]]; then
                        logger -s "Setting MTU of $CONNECTION_ID to $MTU..."
                        if /usr/sbin/ip link set dev $1 mtu $MTU ; then
                                logger "Successfully set MTU of $CONNECTION_ID to $MTU"
                                logger "Failed to set MTU of $CONNECTION_ID to $MTU"

Make sure that file is executable and owned by root

Make sure NetworkManager-dispatcher.service is active

# systemctl enable NetworkManager-dispatcher.service
# systemctl start NetworkManager-dispatcher.service

restart network

# nmcli networking off; modprobe -r bonding ; nmcli networking on

And that should do it.

@magicalyak Thanks for the detailed info here.

Don’t think this relates to our ‘Built on openSUSE’ Rockstor 4 RC variants but currently their Leap 15.2 base NetworkManager is at:

rleap15-2:~ # zypper info NetworkManager | grep Version
Version        : 1.22.10-lp152.2.3.1

We will likely have to look into how the same is accomplished in our openSUSE Leap 15.2 base in time.


nmcli could work

it seems to be there by default.