Just bought a paid subscription, expecting updates to be installed, but nothing happens

Hi there.

I guess this is one for @suman or @phillxnet?

I just went ahead and bought a 3 years subscription to Rockstor.

My reason was that I didn’t like being left behind on the testing channel that hasn’t been upgraded in a very long time. Even though the system has been rock solid (I had a 89 days uptime up till today).
And of course to support a project that I have found to be rather promising, and that has worked well for me.

So I was still at 3.9.1-16, and was expecting some updates to be found and installed.

Instead I’m met with a message saying I’m running the latest version “System is running the latest Rockstor version: 3.9.2-20”.

What should I do to get the latest updates?

I have (of course) tried with a reboot.

I don’t see e.g. the quota update @phillxnet made to 3.9.2-18 (I have tried “Ctrl-Shift-R”), or any of the other changes made over the time.

Please help me getting my Rockstor uptodate again :slight_smile:

I would very much want to avoid reinstalling!

Yum update shows me there is a 3.9.2-20 update available (and a new docker-engine), should I allow it to update?

@KarstenV Hello again and thanks for helping to support Rockstor.

Good to hear.

What you describe is a bug and a rather tricky chicken and egg one at that. It has been fixed but of course only via an update but the system, as you observed, thinks it’s already updated. Rather annoying for all concerned really and the details of what’s happened are to be found in the following now closed issue:


and it’s associated fix / pull request:

But the chicken and egg part (and what adds to the annoyance) is that you don’t get that until you actually update!

Oh well.

All that is needed is a:

yum update rockstor

There after the Web-UI update indicator should work as expected when ever there is a newer version of the rockstor package available. Unfortunately until this is released in the new iso or testing channel we are stuck.

Let us know how it goes and hope that helps.

I ran “yum update rockstor” as instructed and it seems to have worked.

At least I can see some changes in the UI now.

Any Idea when a new kernel is being applied? A lot has changed with BTRFS since 4.12, I think.

Are there any other things I should worry about, scheduled tasks breaking, and those sort of things?

Oh, and youre welcome about the subscription, I decided to support you, since I really like the project, and finally had money to use for the support.

@KarstenV OK, looks like we got cross posts there.

Yes this is another tricky one. You may want to reboot after that docker update (which should be pulled in as a dependency) as we changed to the docker-ce variant and it caused us quite some issues. The last as far as I know is documented in the following issue:

I think you will appreciate the irony of this still open issue. Note though that we are in the throws of addressing such ‘regular’ issues of this type, ie upstream breakage has been more than I for one would have liked. As per kernel updates etc our plans (still in the making) also incorporate an improved situation on that front as well. All in good time is the hope.

At least that unwanted and unwarranted docker-ce quotas behaviour was instrumental in speeding up our quota disabled capabilities so there’s a silver lining.

See how you get on with the scheduled tasks as there was some turmoil on that one but it all depends on when you created the task. I think they should all be ok but if not you would get an email and you would just have to delete and re-create that task. Then it should be fine going forward (down to large api url changes that are now done).

Hope it works out for you and thanks again for helping to sustain our efforts.

And do keep the bug reports coming as there is much to be done but unfortunately everything takes time and usually more than at least I think it’s going to :slight_smile:

Thanks for the answers and the kind help.

I did notice the quotas showed up as being off (and I didn’t disable them AFAIK), They show as on again after the recommended reboot.

After the reboot, I did get a little bit of a scare, as none of my Rock-ons worked anymore.
But I just had to to turn the Rock-on service on, and everything was back to normal.

The scheduled tasks windows looks normal to me, I’ll wait and see if everything works as expected.

1 Like