Kernel panic after update from 3.8-1X(prev stable) to 3.8-13 stable

Hi,

I just upgraded my perfectly working system to the new stable release and get a kernel panic when booting. I can still boot the older kernel.

System: N54l with 3*5TB in RAID5; rockons: plex+owncloud; USB stick as boot medium

any ideas on how to fix this /instuctions on how i can send you more sys info?

Thanks,
Klaus (customer since ~2 months)

1 Like

additional information:

also occurs after deactivating the rockons when booting with old kernel.

more info on kernel panic:
"not syning: VFS: Unable to mount root fs on unknown-block(0,0) -

  • I am not an expert-does this mean an upgrade on USB stick fails?

Klaus

Hi @rockstoruser77github - Klaus, welcome to Rockstor Community!
I’ve already read something similar via Rockstor Github page (while reading of users upgrading without any matter too :slight_smile: ), so we can assume it’s not a bug related to 3.8-13 itself, but instead to 3.8-13 on some specific installations (maybe because of important networking model changes/improvements, i guess)

Can you provide logs/further infos ?? (boot with old kernel and collect rockstor logs / system logs)
As a customer remember to use Rockstor support too

ADD after reading your second post: that seems related to wrong boot opts (usually happening with kernel/grub mods), so you can try by system rescue on boot (that would solve it) or wait for @suman for another opinion

1 Like

THX for the quick answer. Maybe you can link me to the documentation on how to get the logs the easy way? (maybe I overlooked it in the GUI-if not please implement a button to collect this for support in the future)

I dont have any specials settings/installation. Only the HP N54l with a modded BIOS (for AHCI/full speed on all SATA ports).
Rockstor is installed totally the “normal” way from one USB installation-stick to the boot stick (rockstor setup routine).

3WD 5TB disk with a single pool RAID 5

some shares for the rockons that are now also off

That’s like an arrow into my heart: i’m exactly trying to help with that, but i’m late because of work :sweat:

Ok, I’d really like to hear from @suman and/or @phillxnet because I’ve never had Rockstor running from an usb stick so got no experience of that.
If you want to try via rescue: boot and during boot select option with “Rescue”: that should try to solve (worst case: it won’t solve and you’ll have to boot to old kernel again)

1 Like

Thanks for pitching in @Flyer.

@rockstoruser77github, thanks for the detailed report. There’s a known issue with kernels < 4.5 while running the OS from a USB stick. It’s documented on our issue track here. I think @roweryan has tested several kernels and concluded that the problem exists in all 4.3 and 4.4 kernels. 4.5 apparently works, though I am yet to test it. I do have one USB install and it worked on 4.3 and works on 4.4, so the problem not universally on all USB installs.

I am not sure how soon we’ll move to 4.5, but in the mean time you might want to try every installed kernel and see if an older one(4.2?) may work better.

Another random thought is that may be the USB has gone bad? I’ve had this happen a few times where the current install just doesn’t boot(different errors though) but I was able to get more life by doing a reinstall.

I’ll confirm @Flyer’s thought that this is not related to the upgrade, but perhaps more of a coincidence. I know this doesn’t really help you, but I’ll let you know if I come up with any new suggestions. Perhaps others may have ideas for you.

Hi,

Some more details:

I don’t think it’s the USB Stick in this case (Sandisk Ultrafit 32GB USB 3.0, plugged into the internal socket of the N54L)). It has something to do with the installation-update routine/or software components (kernel etc…) as I had to try 10 different sticks to make 2 of them boot.

This specific stick was only used a couple of days and just stopped working after the automatic stable upgrade-but still works with the old kernel from its boot menu.
I guess a reinstall of the new release on the same stick will work again-but that is not how an update should work in the stable branch…

I prefer the USB way-as it saves one SATA connection/bay/energy/noise…, and this works perfectly with FREENAS and OMV. The reason I switched to rockstor is mainly its BTRFS RAID function which uses much less RAM than ZFS and still has the improved flexibility with different disk seizes.

I already convinced a few friends/colleagues to buy some 5Y licenses (4 *5Y in total up to now…)- I hope this will not backfire on me :wink:

Thanks for your support,

(when I have time I will tell you about the success/or not with the same stick and reinstalling the new release- I guess the configbackupfile from .11/12 is still compatible with .13?)

Br,
Klaus

@rockstoruser77github Thanks for the ‘more details’. Don’t like the sound of having to try 10 different sticks. I suspect there is some fussyness on behalf of the hardware there at least; ie on what the N54L will boot that is. As @suman indicated there is a know issue with the newer kernels we are using which has apparently now been fixed upstream so once we move to at least a >= 4.5 we should be good again. The forum member @roweryan looked into this pretty thoroughly I believe. OMV uses a much much older kernel than what we can use due to our btrfs base and FreeNAS as you know is NanoBSD based so they are really quite different animals.

In my own recent tests with the very fast and robust (has proper wear levelling and smart support) Sandisk Extreme USB 3.0 I had very erratic boot reliability (frequent kernel panics on boot). Though I didn’t try with any older kernels as a fairly recent acquisition. Often found a complete power down and up would help it boot but not always. Went back to using msata via pcie adapter for now but now we have usb keys such as this available it would be great to be able to use them for the reasons you give.

While we are working together I don’t think there is any back firing, but for sure there are things that still need to be improved upon and this kind of discussion helps with that. It was rather disappointing to run into this kernel issue thing with the USB boots. But at least it’s fixed upstream now, apparently.

I believe there are other threads on the forum concerning the N54L and the like, maybe there are some tips to be had there. I’m not familiar with them myself though but look like nice little devices, I seem to remember some issues with getting them to boot at all from the usb was a problem at one point: maybe that is your 10 usb keys issue there.

So do let us know how you get on with any re-installs / experiments and as far as I know you should be good to save (and download) and then restore you settings, though do note that not all settings are preserved. There are some notes on this in the Configuration Backup and Restore section of the official docs. There is also relevant info in the Reinstalling Rockstor section re importing from the data drives in the Data Import section.

Oh and thanks for your support also.

2 Likes

freshly installing 3.8-13 on the same USB stick worked.

issues: installation destination selection in the GUI was only working if i removed the 3 RAID 5 disks with data before booting the installation stick. (Python errors another time just no reaction when clicking on the symbol)