Kernel panic after update today

Hi there

After a fresh install i did stable update in the WebGUI. After reboot i got a kernel panic.

Restart with old kernel starts the system like before. Does someone know what’s the problem could be?

Runs on a MacBook with Core 2 Duo.

Thanks for advice.
cracksilver

Hello @cracksilver,

Looks to me like the system was rebooted before the updates were actually complete.

Try running a “sudo yum reinstall kernel” from the cli, then reboot after it is complete.

Hi vesper1978

That was probably my fault. Didn’t see or here something after 5-6 min so i thougt it stocks… an rebooted ;-( bad idea…

So the kernel i’v reinstalled properly. I started like normal. After try access in GUI I got this screen:

first boot after reinstall

second boot after reinstall

if I start with the 4.10 kernel I do not have this kernel panic…

Hi @cracksilver,

Your /boot partition isn’t full, is it? Can you do the following from the cli:

df -h | grep boot

The percentage is the percent of space used. I suspect it isn’t.

Can you also provide the output from:

sudo rpm -qa kernel*

In my case, it returns the following:

kernel-ml-4.10.6-1.el7.elrepo.x86_64
kernel-ml-4.12.4-1.el7.elrepo.x86_64

If there’s plenty of space free in /boot, you can try removing the kernel that’s causing the kernel panic:

sudo yum remove kernel-ml-4.12.4-1.el7.elrepo.x86_64

Above assumes that “kernel-ml-4.12.4-1.el7.elrepo.x86_64” is the kernel you’re having a problem with if not, substitute the kernel you’re having problems with.

That likely should also remove any dependencies that the kernel requires.

Then, you should be able to reinstall it as well as its dependencies with this:

sudo yum update

After that completes, you should be able to reboot and it should be able to successfully boot.

Hi @versper1978

Thank you for answering.

I just installed new from cd. At the moment the stable update in rockstor web-GUI is running. After 5 min web access is gone. Wait for another 10-15 min and see what going on.

What ist the difference between web-GUI update and CLI update with yum update?

I was back in the gui and told to reboot.

Made check in CLI `yum update, there is nothing to update anymore.

In the system (GUI) everything seems to be fine.

I think there was something happening to the filesystem while rebooting during update. Now its clean and stable at the moment.

Thank you for helping me. I’m new in CentOS, normaly used to work with ubuntu and debian.

so the whole sh… again.

Started in 4.10 kernel to do the stuff you ask.

df -h | grep boot

I got:

[root@rockstor ~]# df -h | grep boot
/dev/sda1 477M 126M 322M 29% /boot
[root@rockstor ~]#

seems to be okay.

sudo rpm -qa kernel*

I got:

[root@rockstor ~]# sudo rpm -qa kernel*
kernel-ml-4.10.6-1.el7.elrepo.x86_64
kernel-ml-4.12.4-1.el7.elrepo.x86_64
[root@rockstor ~]#

seems also like the true :wink:

delete bad kernel:

[root@rockstor ~]# sudo yum remove kernel-ml-4.12.4-1.el7.elrepo.x86_64
Geladene Plugins: changelog, fastestmirror
Abhängigkeiten werden aufgelöst
–> Transaktionsprüfung wird ausgeführt
–> Paket kernel-ml.x86_64 0:4.12.4-1.el7.elrepo markiert, um gelöscht zu werden
–> Abhängigkeitsauflösung beendet
Abhängigkeiten aufgelöst

=================================================================>========================================
Package Arch Version Paketquelle Größe
=================================================================>========================================
Entfernen:
kernel-ml x86_64 4.12.4-1.el7.elrepo @rockstor 188 M

Transaktionsübersicht

Entfernen 1 Paket

Installationsgröße: 188 M
Ist dies in Ordnung? [j/N] :j
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Löschen : kernel-ml-4.12.4-1.el7.elrepo.x86_64 1/1
Warnung: file /lib/modules/4.12.4-1.el7.elrepo.x86_64/modules.softdep: remove failed: Datei oder Verzeichnis nicht gefunden
Warnung: file /lib/modules/4.12.4-1.el7.elrepo.x86_64/modules.devname: remove failed: Datei oder >Verzeichnis nicht gefunden
Überprüfung läuft: kernel-ml-4.12.4-1.el7.elrepo.x86_64 1/1

Entfernt:
kernel-ml.x86_64 0:4.12.4-1.el7.elrepo

Komplett!
[root@rockstor ~]#

hmm…?

Are this warnings because I am started with kernel 4.10 ?

Warnung: file /lib/modules/4.12.4-1.el7.elrepo.x86_64/modules.softdep: remove failed: Datei oder Verzeichnis nicht gefunden
Warnung: file /lib/modules/4.12.4-1.el7.elrepo.x86_64/modules.devname: remove failed: Datei oder Verzeichnis nicht gefunden

Those warnings are fine, and I actually expected there to be some which just reassures me that the kernel update was interrupted.

OK

so then, there is no possibility to use this 4.12 kernel. Is it bad to use rockstor or just can’t do some updates anymore? What does it mean for me…?

What happens if you now do a

sudo yum update

?

I get just the new 4.12 kernel to upgrade

I’m working arround with the system the whole evening. Everything works fine.

Now reboot after tried to install subsonic in Rock-on. And see: every share including /home is unmounted

Why this?

Tried this:

[root@rockstor ~]# systemctl restart rockstor-pre
[root@rockstor ~]# systemctl restart rockstor
[root@rockstor ~]# systemctl restart rockstor-bootstrap
Job for rockstor-bootstrap.service failed because the control process exited with error code. See “systemctl status rockstor-bootstrap.service” and “journalctl -xe” for details.
[root@rockstor ~]# systemctl restart rockstor-bootstrap

still unmounted…

Is rockstor really such a stable server that you can use it at home without such incidents? Is it really due to the fact I use older hardware?

cracksilver

@cracksilver Welcome to the Rockstor community and well done for persevering with that kernel version issue. My initial guess was that the 4.12 kernel was just not compatible with the known to be difficult Mac hardware.

2 or 3 of my test machines are far older and far less capable, although I think you may be a first to report using a MacBook. I have used a core 2 duo Dell laptop to test the sdcard capability / compatibility though. But you are at the bottom end of the Minimum system requirements. We are due to update the CPU spec to recommend dual core though, which you already meet of course.

Rockstor, being a full on customisation of CentOS (currently) does not do well if installed on a regular, normally slow, USB stick (time out issues) but you made no mention of that so I’m assuming you have installed to the internal hard drive on this MacBook? It is also best practice to not use the system disk for your data pools. This way you maintain separation between data and system. I.e. you use additional drives to for your data pools. What is the arrangement you are using with this laptop re the storage?

We really need a little more info here to diagnose what’s happened. As in the error message’s suggestion, could you give the output of:

journalctl -xe

after a reboot and then after a few minutes more for things to settle.

Also what version of Rockstor are you running? To be sure we need the output of:

yum info rockstor

I know you indicated a stable channel subscription via:

But there was a chicken and egg bug where the indicated version within the Rockstor UI was that of the available rather than installed. But I suspect this affected moving from testing to stable only.

Lets take it from there.

The “home” subvol mount (at /mnt2/home), at least that presented by Rockstor’s UI, is simply a convenience additional mount of the existing ‘/home’ mount that is controlled by /etc/fstab. The /home, along with the root subvol (/) mount, are controlled by fstab. So something is simply tripping up all of the Rockstor managed subvol mounts. The above info should help to see what that is.

Hope that helps and I’m surprised you have gotten this far with a MacBook in the first place actually. Quite an interesting project really. I do have a similarly aged MacBook here that I may be able to replicate issues on but I currently have a bit of a backlog for a little while yet. Let us know how you get on with this and with the above info we should be able to see what the blocker is; hopefully.

Hi there

Sorry for late reply. There are many things running at the moment.

To the rockstor project on my macbook. After I tried and failed with many other distros and projects above kernel 4.9 I broke up with it, installed pure debian 9.5 with kernel 4.9 and even the other HP Laptop with kernel panic problem runs properly. Never mind, the problem seem to be the kernel not rockstor :wink:

At the moment I run the music server on debian stretch with samba, cockpit and duplicati. And it runs like a clockwork :wink:

BUT, today I got an old I7 laptop with 4GB Ram and integrated SSD HD as a present from a workmate. Cool, this looks like the base for the new rockstor project I think. As soon I have a little spare time I´ll start with it an let you know how it works.

ähhm sorry about my english, I´m not a native english speaker. Living and growed up in Switzerland. So we say cheese in another way ,-)

have a good weekend.
cracksilver

1 Like

Thanks for this post, the kernel re-installation command worked perfectly for me!