Log into samba export without a password

Hi,

So I set up a share and set permissions to 777. Then I exported that share via samba and enabled guest access in the GUI. When I try to log into that share via Windows 7, it still asks me for a username/password and I have to use the user/pass combo I setup for the webui (not the one I setup for the os during install). Any ideas to eliminate the password altogether?

Thanks.

Hi @storinator. Welcome to the Rockstor community.

I have not tried this myself but will try and get back. Here’s the issue for it: https://github.com/rockstor/rockstor-core/issues/732

@storinator This seems like a client side issue. I’ve tested your steps with my Ubuntu 14.04 laptop and when I select guest access in samba export and mount the Share from my laptop’s file browser, it does not prompt me for username/password. So, makes me think if this is a Windows 7 requirement.

I’ll leave you with the recommendation to do some online research. If you need to set custom parameters to the samba export you can do so in the custom configuration text area. Attached is the screenshot as an example.

I have tried setting up SMB the exact same way as you posted but I still get prompted for a login and password in Win10 and Win2016.

Anyone figure out how to get this to work without prompting for a user/pass?

did you remove cached logins? Windows has a habit of “saving” them. Make sure your mapped drives are removed (run a net use on the command line).

Try this
net use \\server\share /delete

then
klist purge

From an answer on this thread - http://serverfault.com/questions/451387/how-to-delete-cached-temporarily-credentials-for-a-network-share-on-a-windows-ma

1 Like

Even with CentOS I prompted for a password

Did you leave admin users blank? you may need to also make sure it is world readable (look at access control on the share).

1 Like

I have exactly the same issue with Rockstor 3.8-12 (linux 4.3.3-1.el7.elrepo.x86_64) in my ESXI VSphere 6.0 update 2 testlab.

Setup is as following

Pool “tank”

  • 3x 16GB vdisks
  • RAID-5
  • No compression, no extra mount options

Share “tankshare”

  • Full pool size
  • No compression
  • Owner: root
  • Group: root
  • Permissions: 777

Samba “tankshare”

  • Admin users: (and tried with ‘admin’)
  • Browseable: yes
  • Guest OK: yes
  • Read only: no (also tried yes)
  • Shadow Copy enabled
  • Snapshot prefix: TANKSNAPSHOT
  • Custom configuration:

Snapshots have been enabled and are working with Shadow Copy…

Tested with two Windows clients:

  • Windows 7 Home Premium (32-bit)
  • Windows 10 Pro (64-bit)

Somehow I’m having the same issue. Do you have other shares with logons or is this the only SMB share? I’m wondering if my other shares are conflicting with it and will try to replicate on samba itself.

Did you try comparing using samba directly without rockstor?

Brand new installation, with just this one and only pool and share.

If you edit the /etc/samba/smb.conf
and add this line between the two mentioned

security = user
map to guest = Bad User
passdb backend = tdbsam

Then restart samba
systemctl restart smb

It will work. Just set guest and browseable options on the share setting. To write, you’ll need to give nobody write access or just make it 777. I have 3 shares with no password and one (plex-data) with a password and it works well.

@suman - this may be a good default value, it basically says if there is no user assigned then don’t keep reprompting, check for guest and if ok, let them in. It is also one of the worst named options I have ever seen.

@Tim - can you see if this works for you?

2 Likes

Thanks for documenting this @magicalyak. I’ve created an issue for this. Hope one of us can get to it soon.

if I were adventurous enough I’d submit the code on github but it may be too much. On a side note, I am hoping to write a rockon for a DNS server that can host AD (I’ve done it manually on the Rockstor server).

1 Like

If you come to a fork in the road, take it – Yogi Berra :smile:

Thank you! I can now confirm the suggested change does work.
After logging into the console and using nano to edit the file, it works like a charm. Tested with a Windows 10 x64 pro machine to verify the connectivity.

Awesome! Enjoy! Sounds like @suman might be able to add this soon by default.

Ok, we’ve taken a long time to fix this, but better late than never right? If you are on testing updates, please try out 3.8-14.04. We need to polish the UI side a bit more, so if you are on stable channel, please be patient for 3.8-15. Many thanks to @magicalyak for helping out on this one!

I’ll test this out this weekend if I get a chance. I think I pinpointed a problem of mine to a Realtek onboard NIC so I got an Intel to see if it helps.

Hi guys I can confirm issue hasn’t been fixed yet on testing updates 3.8-14.08 but the work around from @magicalyak worked like charm.
Thanks all