Lost power not having failed to read system array

So I lost power the other day and when the system came back up Im having failed to read system array. I have 3 disk sdb, sdc, sdd. When I reboot it will say one of those cant be read, and when I reboot is says its a different one that cant be read. It changes every time I reboot. Its also giving me an open_ctree failed, which I assume goes along with the other error. I tried this fix but it didnt work. I hate to keep making post but I really want to get this working properly. I hate that I’m having so many issues.

i have personally only seen open_ctree failed when a disk is somewhat corrupted, it might be due to the power failure. You can try to mount the filesystem with the degraded option (mount -o degraded /dev/sdX /mnt2/XYZ, where sdX is one of your drives and XYZ is the pool name) and check if all drives are displayed with btrfs fi show. If thats the case try running some scrub for that pool, it might fix the (super) blocks for the disk.

1 Like

The thing that has me confused is that after each reboot it shows a different drive at fault, but doesn’t show them all at once being at fault. Ok I just tried that and it gave me the same error as the other guide I followed gave me. “Cant find XXX in /etc/fstab”. I did btrfs show and it shows up all of the drives connected to my RAID card, which Im just using as a JBOD card and using Rockstor for all RAID 5 config.