Lost samba shares / data not accessible

Hi, I was wondering if any of you experienced issue where you lose your shares after reboot and they just don’t come back anymore even after multiple restarts. It has happened to me after the computer was off for a few days and I can’t access any of my smb shares thus the data either. I have 5 HDDs in Raid 6 setup so I’m making assumption that not more than 2 HDDs died on me. I was thinking re-installing Rockstor, but that might cause more issues with recovering the data. Please if you have any ideas on what to try, drop me a line.

Hi. Is the Samba Service active? Do you see the shares via Web-GUI? Is your data pool still visible?

Hi Mark, so it turns out I can’t get into the webGUI anymore. last time I was there though I did see the pool just the shares disappeared. I’m actually sitting at the computer now and it come up with a whole bunch of error messages that I don’t understand to be honest so I’m attaching a photo of it.

After waiting for really long time I managed to get into the GUI and I see that samba is on. Attachine a picture again.

This is an error message I get when I click on the pool that had the shares:

Ok it looks like your BTRFS-Filesystem is broken.
I had a similar situation with my Netgear ReadyNAS before I started using Rockstor.
Happily I was able to restore my data completely because BTRFS has build-in mechanisms for scenarios like this.
I would recommend you to prepare a complete Backup of your data with the folowing steps. If you have an a current Backup you can try to repair the filesystem (run btrfs check --repair / BTRFS Wiki with guides to repair your Filesystem.
If not run the backup. After you got all data saved you can try to repair it without formatting all HDDs.
-Get an (NTFS or EXT4) formatted HDD which is large enough to save all your data
-Check the proper name of your Rockstor pool with the “df” command (might be something like “mnt/yourpool” or “mnt2/yourpool”) and the name of the hdd you have connected for the backup (i.e. a USB HDD “mnt/usb”)
-run btrfs restore /dev/yourRockstorPool /mnt/BackupHDD

This will take some time…
Please note that there can come some prompts when the process handles big files. You have to acknowledge every single prompt with “y”.

Maybe there is a simple and quicker solution for your problem - I’m not a BTRFS expert at all - but I would do the backup first before trying to repair the Filesystem.

Some more informations on BTRFS Restore:

Hi Mark,
thank you for your reply. I was wondering if you could help me with a bit more of a step by step guid on how to repair the file system. I’m trying to google things, but I can’t seem to find what I need (perhaps because I don’t understand things enough). Thank you

Ok. First of all… Do you have a current backup?
When you have on start over and reinstall rockstor with formating all drives.
If not, connect to the machine via ssh after you have connected a harddrive (e.g. Usb) for backup and place the “df“ command and show us the output

Unfortunately I don’t have a way to do a backup so I was just going to risk it and try the repair. There is about 5TB of data and I don’ have anything big enough to take such backup and can’t go out and get something right now. In any case, what I’m trying to say is that I’m ok with risking the repair process without backup

Ok. Try “btrfs check --repair yourpool
This may damage all data irretrievable.
If it fails you maybe can’t run a Backup…

With “df“ you can find out your pool. Might be something like “mnt/pool“.

I must be doing something wrong. I tried to run the repair tool but it seems it didn’t find or couldn’t access my pool. I know it’s called “pool1”. I tried df but that doesn’t show a pool with the name “pool1”. I’m attaching a picture and hopefully you can tell me what am I doing wrong.

Were the harddrives with your pool detected by bios?

What do you get with btrfs fi show ?

Yes, the HDDs are detected in BIOs no problem. I tried mounting in the degraded mode using: “sudo mount -o degraded /dev/sda1 /mnt” but then I don’t get past admin login even though I’m typing in correct password. I’m attaching the error I am seeing.

I get Error message:
ERROR: Could not ope /dev/sda
. … I’m attaching a screenshot

You have to login as root with the Password defined in Rockstor Installation Process