LSI SAS HBA to external JBOD


I have LSI 3801-8E & LSI 9200-16E, but neither of these cards are seen by the system.
Currently I have 2x of the 9200 HBA installed in the system.

lspci doesn’t see them.

The system is a new build with ASUS Z170-AR and Intel Pentium G4400 (3.30GHz / 3MB / LGA1151 / Dual Core / 47W).

Any help is appreciated.

Can anyone provide me some guidance as to where to start looking?

Could this be a driver issue?
I would have expected the device to be visable via lspci.

i know the card is visable as FreeNAS can see it.

please help. :slight_smile:

feeling lost in the ocean here, anyone?

@GIDDION Hello again and sorry to take so long in replying.

I’m afraid I don’t have a lot to contribute however as I don’t as yet have any LSI hw here and haven’t come across this with LSI forum reports.

Rockstor is based on CentOS 7 and if the very basic command of lspci can’t see your card then it won’t exist in any higher level (ie where Rockstor is). My only suggestion currently is that you try a generic CentOS 7 install and if lspci can see the card then try and identify which kernel module is responsible for identifying / driving it. Ie do an lsmod on a linux system that can see the card via lspci.

My suspicion is akin to your own that the upstream elrepo ml kernel that Rockstor uses is missing the required module / modules to activate / enable this card, or that they have been deprecated in the newer kernels which is something we have come across with other hardware.

FreeNAS is NanoBSD based so we have little we can take from that, other than of course that the motherboard is capable of seeing the card which is as you point out something.

Does anyone else have any suggestions on why these cards aren’t showing up in a simple lspci?

I’m running a 9200-8e and it was plug and play. Quick question, do you have any lights on the cards? You said they worked under freenas, was that on a different build, or was that using the same hardware?

1 Like

yes, different build. PE2950

So the 3801 cards do not work. I decided to go through all of the cards I have, which is 3. And none of them work, I tried Ubuntu as well.
The 9200 does work, So I am happy about that part.
lspci sees it, only disappointment is the sas2flash tools for firmware updates from LSI (avago) does not detect a card which is odd. But hey at least one card is working.

If I get the time I will try the 3801 cards back in the PE2950 connected to external RAID box.


You may have to use an efi shell to flash the 9200-16e. I had to do that with mine since the dos flasher kept throwing an error for me.

I opted to bump all the way to P20 since most people seemed to only have issues with ssd’s on P20 and I’m currently not running any. I also chose not to flash the bios back to the card after clearing it, since I’m using it as an HBA not a RAID card.

i was using the Linux firmware tools.
I will look into the EFI shell stuff, I have not done that before. So if you have a link to how that works I’d appreciate it. For now I am pushing forward as it seems to function fine for RockStor.
This card isnt a RAID card only FUSION MPT, MegaRAID.