Minio Rock-on issue

Hi All.

I’m new to Rockstor, moved from Truenas. So far I think its awsome!

I’ve managed to get a few rock-ons working including OVPN and a few others with GUI’s. But I’m struggling with Minio. The Rock-on is configured and start, but when I try to access the UI the page doesn’t load. i’ve tried browsing to port 9000 but nothing. I’ve also noticed, when using the UI button from Rockstor it seems to use a random port.

Any advice?

Ben Walker

1 Like

@benrw67 welcome to the Rockstor community.

I just wanted to add that I have just tested the Rockon on Rockstor 4.0.9 and I am running into the same issues. It installs fine (I used port 9001 as suggested by Rockstor due to some other Rockons running on that port), but the UI button from within the Rockstor WebUI indeed seems to lead to a random port, and trying to connect to it directly “refuses” the connection

Using the Minio UI button I get something like: (https version of the same address doesn’t work) and using port 9001 directly (as defined during install) gets the same result of ERR_CONNECTION_REFUSED.

Hopefully, somebody using the Minio Rockon can help out here.


Thanks @benrw67 for the report, and thanks a lot @Hooverdan for testing it and confirming this behaviors.

It seems that Docker image has changed how it works so we will probably need to adjust our Rock-on definition. The documentation reads:

MinIO Server comes with an embedded web based object browser. Point your web browser to to ensure your server has started successfully.

NOTE: MinIO runs console on random port by default if you wish choose a specific port use --console-address to pick a specific interface and port.

… with a docker run example as follows:

docker run \
  -p 9000:9000 \
  -p 9001:9001 \
  minio/minio server /data --console-address ":9001"

It seems we need to bind a second port and add the new --console-address ":9001" command argument.

I have created a Github issue to track this one so that we can update it:


Maybe @m.mcpherson can shed some light on the overall changes, since he submitted it originally and is presumably still using it.
Since I don’t use MinIO, I got confused reading further into the documentation about some of the parameters being used as it kept referencing to secrets and secrets files instead.