Mount a QNAP disk

Hi, sorry new to Rockstor and linux in general. I am trying to create a Raspberry pi4 NAS, I have everything running but I want to take the disk out of my old QNAP NAS and access it either just to use as it as the source, as my media files are all on there already, or to move the files onto another disk and reformat/part. I tried adding the disk and can see it in the disk manager page, I tried adding the ext3 partition that was listed without formatting it and then expected to be able to see it or assign a pool to it and a share so I could access the data or copy it. But add pool is grayed out. What am I doing wrong?

@SpinDreams, welcome to the Rockstor community. Since Rockstor is focused on the btrfs filesystem, you won’t be able to add an ext3 disk as a pool per se. If you’re already able to mount it, I assume you’re able to see the files (if, for example, you’re using the command line).

If you can, then you should be able to move the files to another disk (or pool of disks) attached to Rockstor that is already formatted under btrfs. You can do that using the command line (quite a few tutorials out there), and then wipe the QNAP disk. Then you would be able to add it to your existing pool or create a new one, which will then format it to the btrfs file system.

Is that what you’re looking for?