Network issue during installation

Hello community!!!

I am totally new on Rockstor and I am facing an issue while I am trying to install it.

Here is the machine where I am trying to install Rockstor:

MB: Gigabyte GA-G41M-Combo (rev. 2.0)
LAN: Onboard Atheros GbE LAN chip (10/100/1000 Mbit)
CPU: Intel(R) Core™2 Duo CPU E7400 @ 2.80GHz
Drives: 240GB SSD

I am installing Rockstor using Rockstor-Leap15.4-generic.x86_64-4.5.8-0.install.iso which I flashed onto a USB stick using BalenaEtcher. When installation completes, it says…

Rockstor is successfully installed.

web-ui is accessible with the following links:
localhost login:

I log in using “root” and the password I set earlier, and it prompts me to do updates, etc.

I type myip as it asks me to do, and I get this…

localhost:~# myip
No DHCP-assigned IP address found.
Use ‘nmtui’ or ‘nmcli’ to set a static IP address.

If I type nmtui there is nothing to edit.

If I type nmcli I see this…

Any idea what I am doing wrong?
Am I using the wrong installation version?
Is it a driver issue?

My router has DHCP enabled!
I have also tried to install other similar NAS software and all went fine, with no issues on my LAN!

Thank you for your time!!!

@simos.sigma welcome to the Rockstor community.

I suspect your issue is related to a missing kernel-firmware package that’s specific to the LAN chip you are using. And the generic driver can’t handle it, since it looks like you’re not having any connectivity at all, otherwise installing that wouldn’t be too difficult (zypper in kernel-fimware-atheros) to check whether that resolves your issue.

You could consider building your own installer using our repository:

You would want to add the kernel-firmware-atheros here:

and that could give you the right connectivity then. Alternatively, I think the tumbleweed version of the Rockstor installer has that kernel firmware package included, at least it shows on my test install of the Tumbleweed version of Rockstor when executing:
zypper info firmware-kernel-atheros

That way you could test it whether that would resolve your issue, before creating your own installer using above method of kiwi-ng.


First of all, thank you for your detailed answer! :slightly_smiling_face:

I installed the “Tumbleweed version of Rockstor” and everything went smoothly.

Can’t I keep this version? Or are there significant differences between Rockstor-Leap15.4-generic.x86_64-4.5.8-0.install and Rockstor-Tumbleweed-generic.x86_64-4.5.8-0.install? Are they designed for different purposes? In my case, should I necessarily build my own installer? Because, to be honest, I don’t fully understand how to do this. As a newbie to all this, I’m feeling lost reading all this information on GitHub.


@simos.sigma glad to see that it worked with the Tumbleweed installer. Fundamentally, you can keep the Tumbleweed installer for now.
OpenSuSEs Tumbleweed is essentially a rolling release of changes, including Linux kernel upgrades that adds the latest changes of its components almost daily. The Leap branch is focused on a more stable release cycle with less frequent updates. Personally, I have been using the Tumbleweed on a test install for quite some time without major issues (but in that setup I am also not using advanced networking configurations like Active Directory integrations, etc. so I don’t have experience on whether stability might be impacted in such use cases).
Selfishly, if we have more users that also embark on a Tumbleweed journey, the more experience we will gain with respect to stability.
But, as usual, independent of which branch (or which NAS solution for that matter) you use, always have good backups of your data, since the NAS (Rockstor or otherwise) should not contain the only copy of your important data :slight_smile:

@phillxnet, @Flox if you want to add your 2 cents here …


@simos.sigma I second what @Hooverdan said.
Plus re:

Our mid term goal is to approach Tumbleweed as our primary target: given SUSE’s ALP is to be based on it. So if it’s working for you then dandy. We do currently have an issue with creating new installers re initial Poetry installs failing: but our current installer already has a version installed: before that Python version incompatibility was introduced against our older Poetry version. But we are already underway with preparing to update both of these: so in time this issue will be resolved. TW is currently our most challenging target, but that is mainly down to us still using some ‘old stuff’. However the current testing channel phase is focused on addressing at least some significant elements of our current technical debt. So we are likely to have some more bumps in the road but I think, in-time, it will have been worth it.

And we are currently still able to build and release testing channel rpms for Tumbleweed, with the most recent being 5.0.4-0 in the last hour or so:

So again, as @Hooverdan stated: this all depends on folks reporting as accurately as they can, issue they find with our latest testing release at report time. We are currently making many changes that often end-up breaking stuff - but that is the nature of progress and with major framework/language updates. In time we are aiming at basing our entire dependencies on Py3.11 or newer. But that is a little way off - but it may be sooner that expected :). But the next step is yet-another Django update - so lets just see how that goes first. Bit by bit.

And on the regular Leap versions: which we intend to see through to the last expected version of 15.6, our new installers should soon have more firmware included. We are just pretty busy with some required Appman Open Collective integration improvements and this last testing release currently. Along with the ongoing testing development. But all in things are looking good. So keep an eye on the downloads page and give us feedback on if newer installers (when they are build) work as per the Tumbleweed. I expect they will: so you will then have more options. But by all means test away with what you have.

Hope that helps.


I am really confused right now… I really want to continue using Rockstor and its Tumbleweed version, which is working for me at the moment, however, I am concerned about its ‘unstable’ nature.

My 2 cents on the stability of TW. I’ve been using it, not in the Rockstor realm for quite some time, and not run into many issues (and I am not necessarily sure those were down to TWs rolling release or some other root causes). As for periodic kernel and btrfs-prog updates (the key piece for Rockstor and the btrfs management), I am using the stable kernel backport on my Leap 15.4 Rockstor instance. Aside from one interim issue in accurately reporting srub statuses, due to a change in the underlying output format, I have not had functional issues in the last year or so.
So, fundamentally, I would say, you’re safe to use TW. Once the next installer(s) contain more kernel-firmware packages as @phillxnet alluded to, and the kernel and btrfs versions are at the same level (for a period of time) you could switch over to a Leap branch (using the backup/restore functionality and re-importing the pools) if you so desire. Introducing the python virtual environment in the recent release and, moving forward, will help isolate many aspects that otherwise could break compatibility…