Network issues upgrading to 4.0

Hi All,

I decided to upgrade from 3.9 to 4.0, I reinstalled and everything was going great, I went into the web ui and set a static IP address which is where my issues started.

The IP Address wasnt updating as expected, I rebooted and then lost connection, turns out it had updated the IP Address but rockstor was still telling me to connect on the DHCP address.

I then decided to assign the IP Address with a static lease through my router (OPNSense) and then re-install rockstor, my device picks up the IP Address during install and works without issue, then it goes offline…

I have no idea why its going offline, my switch shows it connected, ip a shows it connected and running nmcli also shows it connected. However my router shows it as offline which doesnt make sense.

Ive tried everything that I can think of but it doesnt want to work again… any ideas what could be causing this?

I wouldnt mind but the first time I installed it worked perfectly until I tried to set the static IP Address.

Any help would be appreciated :slight_smile:

Personally I think that you should have the option at install to set the IP Address or use DHCP…

@marksie1988 Welcome to the Rockstor community.
Re:

Agreed, this is very strange. Under the hood Rockstor uses Network Manager exclusively, so the source of truth here, from the Rockstor system point of view should be nmcli (Network Manager Common Line Interface).

However; what exactly do you mean by:

Also re:

If you have a functioning static assignment (via DHCP) from your router (for now) then you effectively have a static IP. Work around I know but side steps the problem for now at least. If that is what you are actually referencing. Some routers have the ability to reserve IP addresses for static hosts and there by avoid the allocation otherwise. As opposed to a static DHCP lease for say a specific mac address.

Also agreed. We have the following related issue in our installer repo:

For installing on networks with no DHCP at all. There we may end up suggesting nmtui, an ncurses based Network Manager configuration program, from our myip cli program

What happens if you use nmcli or nmtui to set the static address you are after. Assuming the IP address chosen is not conflicting with a DHCP issued range?

Note that we could well have a bug here. So you may end up having to reboot the system for it to pick up it’s static ip assignment. DHCP is by far our most popular deployment is my understanding. And second to that I suspect is static DHCP leases. But we do also have folks installing on networks with no DHCP at all and they have reported using nmcli or nmtui as work arounds.

Hope that helps.

2 Likes

Thanks for the response, I left it over the weekend and came back to it yesterday, its working now so I have no idea what happened!

2 Likes